summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-05 09:32:11 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-05 09:37:49 +0200
commit2bffeb2808439a8a0f9752f6b47cebeb9fb96508 (patch)
treec2d398415a63b1233207304e96bb1fdcfdc45ad0 /dev-util/trinity/trinity-9999.ebuild
parentprofiles: Remove all dev-qt/qtwebkit references (diff)
downloadgentoo-2bffeb2808439a8a0f9752f6b47cebeb9fb96508.tar.gz
gentoo-2bffeb2808439a8a0f9752f6b47cebeb9fb96508.tar.bz2
gentoo-2bffeb2808439a8a0f9752f6b47cebeb9fb96508.zip
dev-util/trinity: treeclean
Closes: https://bugs.gentoo.org/801457 Closes: https://bugs.gentoo.org/717114 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-util/trinity/trinity-9999.ebuild')
-rw-r--r--dev-util/trinity/trinity-9999.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-util/trinity/trinity-9999.ebuild b/dev-util/trinity/trinity-9999.ebuild
deleted file mode 100644
index 3910c2f87cdd..000000000000
--- a/dev-util/trinity/trinity-9999.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit toolchain-funcs git-r3
-
-EGIT_REPO_URI="https://github.com/kernelslacker/trinity.git"
-
-DESCRIPTION="A Linux system call fuzz tester"
-HOMEPAGE="http://codemonkey.org.uk/projects/trinity/ https://github.com/kernelslacker/trinity/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples"
-
-# We need newer headers to avoid compilation failures in the BPF stuff.
-DEPEND="
- >=sys-kernel/linux-headers-4.8
-"
-
-src_prepare() {
- sed -e 's/-g -O2//' \
- -e 's/-D_FORTIFY_SOURCE=2//' \
- -e 's/-Werror//' \
- -e '/-o $@/s/$(LDFLAGS) //' \
- -i Makefile || die
-
- tc-export CC
- default
-}
-
-src_compile() {
- emake V=1
-}
-
-src_install() {
- dobin ${PN}
- dodoc Documentation/* README
- doman trinity.1
-
- if use examples ; then
- exeinto /usr/share/doc/${PF}/scripts
- doexe scripts/*
- docompress -x /usr/share/doc/${PF}/scripts
- fi
-}