summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-11-16 02:41:19 +0100
committerSam James <sam@gentoo.org>2024-11-16 21:39:06 +0000
commit387f807dc8dc31a4218e362bec28acba4ce3c61e (patch)
tree7f390b71d6b6019060d22b192d755adff836e589 /sci-mathematics
parentmedia-gfx/openscad: add 20241111 (diff)
downloadgentoo-387f807dc8dc31a4218e362bec28acba4ce3c61e.tar.gz
gentoo-387f807dc8dc31a4218e362bec28acba4ce3c61e.tar.bz2
gentoo-387f807dc8dc31a4218e362bec28acba4ce3c61e.zip
sci-mathematics/manifold: bump to 3.0.0_pre20241115
Drop RESTRICT=mirror. Ignore CXXFLAGS set by the build system. Don't pass -ggdb as that should be set via user-CXXFLAGS. Add metadata.xml. Add myself as maintainer. Adjust ebuild style to fit the rest my ebuilds. Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/manifold/Manifest2
-rw-r--r--sci-mathematics/manifold/manifold-3.0.0_pre20241115.ebuild (renamed from sci-mathematics/manifold/manifold-3.0.0_pre20241108.ebuild)43
-rw-r--r--sci-mathematics/manifold/metadata.xml15
3 files changed, 40 insertions, 20 deletions
diff --git a/sci-mathematics/manifold/Manifest b/sci-mathematics/manifold/Manifest
index fd902480b99b..58b71739343e 100644
--- a/sci-mathematics/manifold/Manifest
+++ b/sci-mathematics/manifold/Manifest
@@ -1 +1 @@
-DIST manifold-3.0.0_pre20241108.tar.gz 29138377 BLAKE2B 4b12bf934ad1bef70aa24dad84898cef62dcd2cade2f2c7314775cc50f07ff952d7686b1585bcf1bab492a905d17f4cd14ebc1b56eba666b72a2bbc255ca685b SHA512 fb871468613bedb84d558e124f3ed8ebe90fb1377047c3a519a64d212b4a28332719e070e7730ac3dcd2360d518f773dda040e37da1e86d7bd768fc8c1ffee0a
+DIST manifold-3.0.0_pre20241115.tar.gz 29143605 BLAKE2B 84c3e4c98a9279187660f31e4010097de431472412f2591943c99195edad9f700115df4b362d968b95e3ee136c699eecf2dc9845001019f71e9cf7b0cbca4d0e SHA512 bae671d190d8fbfc0ee12989a73a38d7d0ddf0e0081db8f56a446c09998e24f43828d70731f97d6948599f31ef6734f86183debc09f4cec07983af317ce0dba8
diff --git a/sci-mathematics/manifold/manifold-3.0.0_pre20241108.ebuild b/sci-mathematics/manifold/manifold-3.0.0_pre20241115.ebuild
index 69c4db1a7054..3e6c99c118e9 100644
--- a/sci-mathematics/manifold/manifold-3.0.0_pre20241108.ebuild
+++ b/sci-mathematics/manifold/manifold-3.0.0_pre20241115.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-COMMIT=66bca6e3fdfce0f590ca84edc1a6256502636f4b
+COMMIT=e7e0780114881dcf6e5ad934323f2595966865f9
PYTHON_COMPAT=( python3_{10..13} )
inherit cmake python-single-r1
@@ -19,17 +19,17 @@ KEYWORDS="~amd64"
IUSE="debug python test"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test ) mirror"
+RESTRICT="!test? ( test )"
RDEPEND="
- dev-cpp/tbb
+ dev-cpp/tbb:=
sci-mathematics/clipper2
python? ( ${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/numpy[${PYTHON_USEDEP}]
')
)
- "
+"
DEPEND="
python? (
$(python_gen_cond_dep '
@@ -37,27 +37,32 @@ DEPEND="
')
)
test? ( dev-cpp/gtest )
- ${RDEPEND}"
+ ${RDEPEND}
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed \
+ -e "/list(APPEND MANIFOLD_FLAGS/s/^/# DONOTSET /" \
+ -i CMakeLists.txt || die
+}
src_configure() {
local mycmakeargs=(
- -DMANIFOLD_CROSS_SECTION=ON
- -DMANIFOLD_DEBUG=$(usex debug)
- -DMANIFOLD_DOWNLOADS=OFF
- -DMANIFOLD_EXPORT=OFF
- -DMANIFOLD_JSBIND=OFF
- -DMANIFOLD_PAR=ON
- -DMANIFOLD_PYBIND=$(usex python)
- -DMANIFOLD_TEST=$(usex test)
+ -DMANIFOLD_CROSS_SECTION="yes"
+ -DMANIFOLD_DEBUG="$(usex debug)"
+ -DMANIFOLD_DOWNLOADS="no"
+ -DMANIFOLD_EXPORT="no"
+ -DMANIFOLD_JSBIND="no"
+ -DMANIFOLD_PAR="no"
+ -DMANIFOLD_PYBIND="$(usex python)"
+ -DMANIFOLD_TEST="$(usex test)"
)
- if use debug; then
- mycmakeargs+=(
- -DMANIFOLD_FLAGS=-ggdb
- )
- fi
+
cmake_src_configure
}
src_test() {
- "${BUILD_DIR}"/test/manifold_test || die
+ "${BUILD_DIR}/test/manifold_test" || die
}
diff --git a/sci-mathematics/manifold/metadata.xml b/sci-mathematics/manifold/metadata.xml
new file mode 100644
index 000000000000..7a2cd57d4d26
--- /dev/null
+++ b/sci-mathematics/manifold/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>negril.nx+gentoo@gmail.com</email>
+ <name>Paul Zander</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">elalish/manifold</remote-id>
+ </upstream>
+</pkgmetadata>