summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-04 22:54:46 +0000
committerSam James <sam@gentoo.org>2023-02-04 22:54:46 +0000
commitcf183ec7d9060b22d3ef0e2001512aca139e88a4 (patch)
treea65f2dcfe89065348a26605dfe7929512ee6c2d9 /sys-process/htop
parentsys-fs/fuse: add 3.13.1 (diff)
downloadgentoo-cf183ec7d9060b22d3ef0e2001512aca139e88a4.tar.gz
gentoo-cf183ec7d9060b22d3ef0e2001512aca139e88a4.tar.bz2
gentoo-cf183ec7d9060b22d3ef0e2001512aca139e88a4.zip
sys-process/htop: add 3.2.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/htop')
-rw-r--r--sys-process/htop/Manifest1
-rw-r--r--sys-process/htop/htop-3.2.2.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/sys-process/htop/Manifest b/sys-process/htop/Manifest
index dee143fae774..193049475da4 100644
--- a/sys-process/htop/Manifest
+++ b/sys-process/htop/Manifest
@@ -1 +1,2 @@
DIST htop-3.2.1.tar.xz 406048 BLAKE2B 7addefca7de8f0867220e6415f4585f7e6ecf655d6245e4a8e120552ac738544fde1c2d8e24ce1139209caad23994316e8be9611f6ed0253d60547158d17ff24 SHA512 f412c10ebdec4fb026fb93a79a9b0b84612ad5a0d28e37f06713e6c895f70e92cbd09a8737d04f3d51102295d7a419eb2c3ec3907b96f553fda8ff3d1a2142b6
+DIST htop-3.2.2.tar.xz 384820 BLAKE2B da3b4aea4e5d32d4b432e0f45089e7795b59d9a947dc4af76cb6b7f9137e6d45901c8169c8d2c796a3f43162c1e3c8f1e18bd17f20750637e06fe4c3ebe22caa SHA512 59f3f06677076262e25a478552e4438ce37028e2f064d3fb78653d3213b48ae4d78c7e0d62ee785a4ed3c6c99b7faafd9afab94c4350a4e5c5843cef81aaf489
diff --git a/sys-process/htop/htop-3.2.2.ebuild b/sys-process/htop/htop-3.2.2.ebuild
new file mode 100644
index 000000000000..7080f7e4ba08
--- /dev/null
+++ b/sys-process/htop/htop-3.2.2.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+# We avoid xdg.eclass here because it'll pull in glib, desktop utils on
+# htop which is often used on headless machines. bug #787470
+inherit linux-info optfeature python-any-r1 xdg-utils
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="https://htop.dev/ https://github.com/htop-dev/htop"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/htop-dev/htop.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://github.com/htop-dev/htop/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+S="${WORKDIR}/${P/_}"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="caps debug delayacct hwloc lm-sensors llvm-libunwind openvz unicode unwind vserver"
+
+RDEPEND="
+ sys-libs/ncurses:=[unicode(+)?]
+ hwloc? ( sys-apps/hwloc:= )
+ unwind? (
+ !llvm-libunwind? ( sys-libs/libunwind:= )
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ )
+ kernel_linux? (
+ caps? ( sys-libs/libcap )
+ delayacct? ( dev-libs/libnl:3 )
+ lm-sensors? ( sys-apps/lm-sensors )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog README )
+
+CONFIG_CHECK="~TASKSTATS ~TASK_XACCT ~TASK_IO_ACCOUNTING ~CGROUPS"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ if [[ ${CBUILD} != ${CHOST} ]] ; then
+ # bug #328971
+ export ac_cv_file__proc_{meminfo,stat}=yes
+ fi
+
+ local myeconfargs=(
+ --enable-unicode
+ $(use_enable debug)
+ $(use_enable hwloc)
+ $(use_enable !hwloc affinity)
+ $(use_enable openvz)
+ $(use_enable unicode)
+ $(use_enable unwind)
+ $(use_enable vserver)
+ )
+
+ if use kernel_linux ; then
+ myeconfargs+=(
+ $(use_enable caps capabilities)
+ $(use_enable delayacct)
+ $(use_enable lm-sensors sensors)
+ )
+ else
+ if use kernel_Darwin ; then
+ # Upstream default to checking but --enable-affinity
+ # overrides this. Simplest to just disable on Darwin
+ # given it works on BSD anyway.
+ myeconfargs+=( --disable-affinity )
+ fi
+
+ myeconfargs+=(
+ --disable-capabilities
+ --disable-delayacct
+ --disable-sensors
+ )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ optfeature "Viewing processes accessing certain files" sys-process/lsof
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}