summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/bytestring-handle/Manifest1
-rw-r--r--dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/bytestring-handle/Manifest b/dev-haskell/bytestring-handle/Manifest
index 9bc2f5d0f1bd..7ded61074048 100644
--- a/dev-haskell/bytestring-handle/Manifest
+++ b/dev-haskell/bytestring-handle/Manifest
@@ -1 +1,2 @@
DIST bytestring-handle-0.1.0.4.tar.gz 6204 BLAKE2B bcda8d126b5e60f1f78be576ec0233f8b0afe80409afd9a796c0a86e83f3b05702eb40ed09af1ebb2d2b8b194924084a0799ca6b498acd654a18d679b1184415 SHA512 17649968ffbebf1a567059ecf3f19e8d8f6a1bb53a0b491e35b62d572cff9f949822953452ee72d193546d8779d6d71dfd82ae5cfd2d3b7564ac73df7283facb
+DIST bytestring-handle-0.1.0.6.tar.gz 6203 BLAKE2B e821b33a97983e124c679c2b9f2316151e695ebf615f739d50b5d4524804878dddb861d2abd7708ad635cd563a007e867232f81f229b368b5ca4afb90d4730cf SHA512 a585488207680a6f1ba6538cf10d03e059010d42994803f9edc6d9c1fff08e479117a6d1449f923a8d5de9884b93438e80b81c75978e5c3145310c21ba14498c
diff --git a/dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild b/dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild
new file mode 100644
index 000000000000..fa9840c071ac
--- /dev/null
+++ b/dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="ByteString-backed Handles"
+HOMEPAGE="http://hub.darcs.net/ganesh/bytestring-handle"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
+ >=dev-haskell/quickcheck-2.1.2
+ >=dev-haskell/test-framework-0.2.0 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.0 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.2.5 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.2 && < 4.11' 'base >= 4.2' \
+ 'QuickCheck >= 2.1.2 && < 2.11' 'QuickCheck >= 2.1.2'
+}