summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/image_geometry/image_geometry-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-ros/image_geometry/image_geometry-9999.ebuild b/dev-ros/image_geometry/image_geometry-9999.ebuild
index 4b65c37fb167..2cfbe286ffa0 100644
--- a/dev-ros/image_geometry/image_geometry-9999.ebuild
+++ b/dev-ros/image_geometry/image_geometry-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/vision_opencv"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -16,7 +15,8 @@ IUSE=""
RDEPEND="
media-libs/opencv:=
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] dev-cpp/gtest )"