summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/backports-functools-lru-cache/Manifest1
-rw-r--r--dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.2.ebuild41
-rw-r--r--dev-python/backports-functools-lru-cache/metadata.xml14
-rw-r--r--dev-python/backports-unittest-mock/Manifest1
-rw-r--r--dev-python/backports-unittest-mock/backports-unittest-mock-1.1.1.ebuild38
-rw-r--r--dev-python/backports-unittest-mock/metadata.xml14
-rw-r--r--dev-util/idea-ultimate/Manifest2
-rw-r--r--dev-util/idea-ultimate/idea-ultimate-16.0.0.144.2608.2_pre.ebuild (renamed from dev-util/idea-ultimate/idea-ultimate-15.0.3.143.1453.5_pre.ebuild)9
-rw-r--r--dev-util/idea-ultimate/metadata.xml3
9 files changed, 119 insertions, 4 deletions
diff --git a/dev-python/backports-functools-lru-cache/Manifest b/dev-python/backports-functools-lru-cache/Manifest
new file mode 100644
index 000000000000..6fb6571f1096
--- /dev/null
+++ b/dev-python/backports-functools-lru-cache/Manifest
@@ -0,0 +1 @@
+DIST backports.functools_lru_cache-1.2.tar.gz 5325 SHA256 c2dab0234ef7b0cddfebc46a4c61e9fdbd87d824f356c24a355f6b4446068da4 SHA512 4f537fa2c61b9e2e77148fa0eb1c4ce49c4238a032d6009c66e71d1a41a2ec0cf187902ff448d3fc4603e03c35fed52513546fac08184ad5a806e518a98d58ac WHIRLPOOL af26a7edc20bc7ea8d38fbcabe7b418cff4ac1b7f33607513e0db9f0537a26f5ebac7521eda50481b964f2cae9f4e53bc57e51d76f633f0806e95c1a72d9dc76
diff --git a/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.2.ebuild b/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.2.ebuild
new file mode 100644
index 000000000000..edcd64a4df25
--- /dev/null
+++ b/dev-python/backports-functools-lru-cache/backports-functools-lru-cache-1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+MY_PN="${MY_PN//-/_}"
+DESCRIPTION="Backport of functools.lru_cache from Python 3.3"
+HOMEPAGE="https://github.com/jaraco/backports.functools_lru_cache"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test && has_version "${CATEGORY}/${PN}"; then
+ die "Ensure $PN is not already installed or the test suite will fail"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/backports-functools-lru-cache/metadata.xml b/dev-python/backports-functools-lru-cache/metadata.xml
new file mode 100644
index 000000000000..1b0a4e9d2b59
--- /dev/null
+++ b/dev-python/backports-functools-lru-cache/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">backports.functools_lru_cache</remote-id>
+ <remote-id type="github">jaraco/backports.functools_lru_cache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/backports-unittest-mock/Manifest b/dev-python/backports-unittest-mock/Manifest
new file mode 100644
index 000000000000..1ccc06c46b9c
--- /dev/null
+++ b/dev-python/backports-unittest-mock/Manifest
@@ -0,0 +1 @@
+DIST backports.unittest_mock-1.1.1.tar.gz 3255 SHA256 641bd99befaa09834df2aa5f01a0db27c782758e06d46831bfae6ff91dc5d1be SHA512 82872d9ada74b7e64792b29cd49177d5c54ffd64260ce17628df7df08e9e16ee1456d9f80eacacebb43a5e51ad93868cd49bee84209cf6682385e746bcfc90c4 WHIRLPOOL e1c1728a6a2aa0a2ec58a57b23874deb1167d2e3599a20d5e1331ab97e34798519956cb5b20bed735c7a714b6d258944f32144997a9763462c3d373e28a68267
diff --git a/dev-python/backports-unittest-mock/backports-unittest-mock-1.1.1.ebuild b/dev-python/backports-unittest-mock/backports-unittest-mock-1.1.1.ebuild
new file mode 100644
index 000000000000..98be0c6d8060
--- /dev/null
+++ b/dev-python/backports-unittest-mock/backports-unittest-mock-1.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# It is the developer's intention that backports.unittest_mock will be
+# used even for Python 3: https://github.com/jaraco/jaraco.timing/pull/1
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+MY_PN="${MY_PN//-/_}"
+DESCRIPTION="Backport of unittest.mock"
+HOMEPAGE="https://github.com/jaraco/backports.unittest_mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/mock[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ py.test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/backports-unittest-mock/metadata.xml b/dev-python/backports-unittest-mock/metadata.xml
new file mode 100644
index 000000000000..2a913a105d34
--- /dev/null
+++ b/dev-python/backports-unittest-mock/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">backports.unittest_mock</remote-id>
+ <remote-id type="github">jaraco/backports.unittest_mock</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/idea-ultimate/Manifest b/dev-util/idea-ultimate/Manifest
index f2ffc4d4a259..62fb28900b0c 100644
--- a/dev-util/idea-ultimate/Manifest
+++ b/dev-util/idea-ultimate/Manifest
@@ -1,4 +1,4 @@
DIST idea-ultimate-14.1.5.141.2735.5.tar.gz 318054935 SHA256 6912902ec97a57f5553247367d6dd5b8e3041e99faf32c48b672cd31413dab73 SHA512 7ab3a45593c2324957455b254ae0257a36e8ecbc63014e18feba813413432dccb25d18971840f43cf22174c3338738eec44304091eb30c6ba2d0119b73cc6fa0 WHIRLPOOL 44a4bef99fdb638cf3cb0f24559b7765b7a4c7cb94aed5c3b8e503cbdf9fa1354f6d6026a9650fc58faec037b95482190891681f41219c61fc7d67a40e71f168
DIST ideaIU-143.1184.17.tar.gz 390459277 SHA256 5a3f6d8ba6d5ce8c505f13564c04cf2f674f1c022b9a33871013acb0ebe10fe5 SHA512 bc42244554ed0e533c95b65b1518ffb20ad1407fab22afff0ff3711245d15d97456599bebfcf654553b91a24dcf9042ac769041be3bfc14af76fa48b70f29d94 WHIRLPOOL 48ba83f0254e027a8f78d070dd55a63d97225ae763107149db8820d22ceb4dc72d080704bb6ea2ccf0673af77ec9cda9fa13b226c0c885f7336f2e7d50b52ae2
-DIST ideaIU-143.1453.5.tar.gz 391976664 SHA256 44cec195e78e65e79c8b609a6cb3ada75ef632fe3a73b8d0ad40610a5e95dfbf SHA512 77e229f08b840ee0b572f5d8036d508ea609f0355a84c64e2bca4dcb8bbe9a2262a1ed46cdd966e9cfd7c8a24a48a3ba3578e229860b27e34a82af57712811a6 WHIRLPOOL 90cc48a9a6bbef67a1c607e73f80aacb70a1f290acfa684775da44eb50e6ec9d6dfed1cf55ce76762afe96e5046cc9cb74d392ce6f3eb644944a2b9e06d14917
DIST ideaIU-143.382.35.tar.gz 379524583 SHA256 1f4c6f55eeb0ce08f697008935c5b7356e74a85dfaad00f6521670b8f5c6862f SHA512 cd3fe075be726695144a70b8f6477a7d547ca6c67bfacdf91d64f352066305d18ad0696608ac54d316adb95b3ae7d4d1218d34b28875a084de35dc03da77b91f WHIRLPOOL 99ba3fb796f40bd8cf22c42302fec7e279dc749b681952066d49f6a079ca06e532cc10274bc19a6b12a81cb6f15ebcde8450f774109a6d21a9a8c9b9ea235710
+DIST ideaIU-144.2608.2.tar.gz 442803534 SHA256 4407049fe9b38d72dcd3540de237aef5528a5e52724d123c7392cefff685ee71 SHA512 f73db0f68b4570faa879f7a411349b21fdf12e4306e81d439bdfe34c0fb8e1baa9f2789c1f6223ca9588a3de6fedb7a52fc89ddbfc2445e1a041db393999a1c4 WHIRLPOOL 1c3da7ff4a85d63f15daed4d8f7e6a7ae52ebc3a42ec8b776312b19c17c7bab2ff1d383734430b105247ed62d998874fd7496c0378d59ff99c17b769b75ed712
diff --git a/dev-util/idea-ultimate/idea-ultimate-15.0.3.143.1453.5_pre.ebuild b/dev-util/idea-ultimate/idea-ultimate-16.0.0.144.2608.2_pre.ebuild
index ef380e48bb22..ea272d825574 100644
--- a/dev-util/idea-ultimate/idea-ultimate-15.0.3.143.1453.5_pre.ebuild
+++ b/dev-util/idea-ultimate/idea-ultimate-16.0.0.144.2608.2_pre.ebuild
@@ -15,7 +15,7 @@ if [[ "$(get_version_component_range 7)x" = "prex" ]]
then
# upstream EAP
KEYWORDS="~amd64 ~x86"
- MY_FILENAME="${MY_PN}IU-${PV_STRING}.tar.gz"
+ MY_FILENAME="${MY_PN}IU-${PV_STRING}-custom-jdk-linux.tar.gz"
else
# upstream stable
KEYWORDS="amd64 x86"
@@ -24,11 +24,11 @@ fi
DESCRIPTION="A complete toolset for web, mobile and enterprise development"
HOMEPAGE="http://www.jetbrains.com/idea"
-SRC_URI="http://download-cf.jetbrains.com/idea/${MY_FILENAME} -> ${MY_PN}IU-${PV_STRING}.tar.gz"
+SRC_URI="http://download.jetbrains.com/idea/${MY_FILENAME} -> ${MY_PN}IU-${PV_STRING}.tar.gz"
LICENSE="IDEA
|| ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
-IUSE=""
+IUSE="-custom-jdk"
DEPEND="!dev-util/${PN}:14
!dev-util/${PN}:15"
@@ -54,6 +54,9 @@ src_prepare() {
fi
rm -r plugins/tfsIntegration/lib/native/solaris || die
rm -r plugins/tfsIntegration/lib/native/hpux || die
+ if ! use custom-jdk; then
+ rm -r jre || die
+ fi
}
src_install() {
diff --git a/dev-util/idea-ultimate/metadata.xml b/dev-util/idea-ultimate/metadata.xml
index 78f55507260f..e787117837fa 100644
--- a/dev-util/idea-ultimate/metadata.xml
+++ b/dev-util/idea-ultimate/metadata.xml
@@ -14,4 +14,7 @@
<longdescription lang="en">
Excel at enterprise, mobile and web development with Java, Scala and Groovy, with all the latest modern technologies and frameworks available out of the box.
</longdescription>
+ <use>
+ <flag name="custom-jdk">Install and use IntelliJ's custom JRE.</flag>
+ </use>
</pkgmetadata>