summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/qemu-4.0.0-r3.ebuild11
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild11
2 files changed, 10 insertions, 12 deletions
diff --git a/app-emulation/qemu/qemu-4.0.0-r3.ebuild b/app-emulation/qemu/qemu-4.0.0-r3.ebuild
index 17814190338b..bd09a33e9d46 100644
--- a/app-emulation/qemu/qemu-4.0.0-r3.ebuild
+++ b/app-emulation/qemu/qemu-4.0.0-r3.ebuild
@@ -49,8 +49,7 @@ IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
# Allow no targets to be built so that people can get a tools-only build.
# Block USE flag configurations known to not work.
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
qemu_softmmu_targets_arm? ( fdt )
qemu_softmmu_targets_microblaze? ( fdt )
qemu_softmmu_targets_mips64el? ( fdt )
@@ -170,12 +169,12 @@ PPC64_FIRMWARE_DEPEND="
"
BDEPEND="
+ ${PYTHON_DEPS}
dev-lang/perl
sys-apps/texinfo
virtual/pkgconfig
doc? ( dev-python/sphinx )
gtk? ( nls? ( sys-devel/gettext ) )
- python? ( ${PYTHON_DEPS} )
test? (
dev-libs/glib[utils]
sys-devel/bc
@@ -191,8 +190,8 @@ CDEPEND="
qemu_softmmu_targets_ppc64? ( ${PPC64_FIRMWARE_DEPEND} )
"
DEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
kernel_linux? ( >=sys-kernel/linux-headers-2.6.35 )
- python? ( ${PYTHON_DEPS} )
static? (
${ALL_DEPEND}
${SOFTMMU_TOOLS_DEPEND}
@@ -404,10 +403,10 @@ qemu_src_configure() {
# are enabled), but it's not really worth the hassle. Disable it
# all the time to avoid automatically detecting it. #568856
--disable-gcrypt
+ --python="${PYTHON}"
--cc="$(tc-getCC)"
--cxx="$(tc-getCXX)"
--host-cc="$(tc-getBUILD_CC)"
- $(use python && echo "--python=${PYTHON}")
$(use_enable debug debug-info)
$(use_enable debug debug-tcg)
$(use_enable doc docs)
@@ -542,7 +541,7 @@ qemu_src_configure() {
src_configure() {
local target
- use python && python_setup
+ python_setup
softmmu_targets= softmmu_bins=()
user_targets= user_bins=()
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 85985f8a2ecb..60bf2213431b 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -49,8 +49,7 @@ IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
# Allow no targets to be built so that people can get a tools-only build.
# Block USE flag configurations known to not work.
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
qemu_softmmu_targets_arm? ( fdt )
qemu_softmmu_targets_microblaze? ( fdt )
qemu_softmmu_targets_mips64el? ( fdt )
@@ -170,12 +169,12 @@ PPC64_FIRMWARE_DEPEND="
"
BDEPEND="
+ ${PYTHON_DEPS}
dev-lang/perl
sys-apps/texinfo
virtual/pkgconfig
doc? ( dev-python/sphinx )
gtk? ( nls? ( sys-devel/gettext ) )
- python? ( ${PYTHON_DEPS} )
test? (
dev-libs/glib[utils]
sys-devel/bc
@@ -191,8 +190,8 @@ CDEPEND="
qemu_softmmu_targets_ppc64? ( ${PPC64_FIRMWARE_DEPEND} )
"
DEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
kernel_linux? ( >=sys-kernel/linux-headers-2.6.35 )
- python? ( ${PYTHON_DEPS} )
static? (
${ALL_DEPEND}
${SOFTMMU_TOOLS_DEPEND}
@@ -402,10 +401,10 @@ qemu_src_configure() {
# are enabled), but it's not really worth the hassle. Disable it
# all the time to avoid automatically detecting it. #568856
--disable-gcrypt
+ --python="${PYTHON}"
--cc="$(tc-getCC)"
--cxx="$(tc-getCXX)"
--host-cc="$(tc-getBUILD_CC)"
- $(use python && echo "--python=${PYTHON}")
$(use_enable debug debug-info)
$(use_enable debug debug-tcg)
$(use_enable doc docs)
@@ -540,7 +539,7 @@ qemu_src_configure() {
src_configure() {
local target
- use python && python_setup
+ python_setup
softmmu_targets= softmmu_bins=()
user_targets= user_bins=()