summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gtest')
-rw-r--r--dev-cpp/gtest/files/gtest-1.8.0-increase-clone-stack-size.patch14
-rw-r--r--dev-cpp/gtest/gtest-1.8.0.ebuild1
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild1
3 files changed, 16 insertions, 0 deletions
diff --git a/dev-cpp/gtest/files/gtest-1.8.0-increase-clone-stack-size.patch b/dev-cpp/gtest/files/gtest-1.8.0-increase-clone-stack-size.patch
new file mode 100644
index 000000000000..22ac0b6d4a12
--- /dev/null
+++ b/dev-cpp/gtest/files/gtest-1.8.0-increase-clone-stack-size.patch
@@ -0,0 +1,14 @@
+Bug: https://bugs.gentoo.org/629620
+Upstream PR: https://github.com/google/googletest/pull/1274
+
+--- a/googletest/src/gtest-death-test.cc
++++ b/googletest/src/gtest-death-test.cc
+@@ -1070,7 +1070,7 @@
+
+ if (!use_fork) {
+ static const bool stack_grows_down = StackGrowsDown();
+- const size_t stack_size = getpagesize();
++ const size_t stack_size = getpagesize() * 10;
+ // MMAP_ANONYMOUS is not defined on Mac, so we use MAP_ANON instead.
+ void* const stack = mmap(NULL, stack_size, PROT_READ | PROT_WRITE,
+ MAP_ANON | MAP_PRIVATE, -1, 0);
diff --git a/dev-cpp/gtest/gtest-1.8.0.ebuild b/dev-cpp/gtest/gtest-1.8.0.ebuild
index 308a12ff6fdb..afb24f111d5c 100644
--- a/dev-cpp/gtest/gtest-1.8.0.ebuild
+++ b/dev-cpp/gtest/gtest-1.8.0.ebuild
@@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-9999-fix-py-tests.patch
"${FILESDIR}"/${PN}-9999-fix-gcc6-undefined-behavior.patch
"${FILESDIR}"/${PN}-1.8.0-multilib-strict.patch
+ "${FILESDIR}"/${PN}-1.8.0-increase-clone-stack-size.patch
)
S="${WORKDIR}"/googletest-release-${PV}
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index a4ab55ca6f1e..79195676d089 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -29,6 +29,7 @@ RDEPEND="!dev-cpp/gmock"
PATCHES=(
"${FILESDIR}"/${PN}-9999-fix-gcc6-undefined-behavior.patch
+ "${FILESDIR}"/${PN}-1.8.0-increase-clone-stack-size.patch
)
pkg_setup() {