summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/intel-compute-runtime')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest2
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789-r3.ebuild69
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992-r3.ebuild69
3 files changed, 0 insertions, 140 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index fe8cb4fb783d..97f366944ca9 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -1,5 +1,3 @@
-DIST intel-compute-runtime-22.13.22789.tar.gz 5252140 BLAKE2B 81fe85e75b1f6257771950dd2716e48f8db61dbe62f747c13ed00be7385c9e6a2f2cd2a5d50cf4253962d13bd1fdb4449a5e646fe3a8b10af228f746b9880210 SHA512 e4d22d8f73463300424b2df9a9634f0b5ac341131de33e57d46ffd52ce0b3fbdbf62cf591876d2143ca14caeba42ec95f5aef201eb9895e5d36b2279b15e661c
-DIST intel-compute-runtime-22.16.22992.tar.gz 5334525 BLAKE2B e2fd74084cddc8163eff46cf267c33206c240b8e7c513d2408dabcc0290182fcb5ce7a8909dca93cbb6fd95c2130448498845602590ff59487508b7adcb2bd65 SHA512 7a133a97f437dfe62559097e41583db60e54af6937cfcb3613f4c54340919a0ee0136cfcea1fb6005341021a9bb139c40be8d237afa2a246accd0af1a20dd297
DIST intel-compute-runtime-22.17.23034.tar.gz 5345890 BLAKE2B 0cd4b9c117978c9127ff1b9e985ab097e672b228a0bba39ad868881af94e821683afb45f394951776f0ecb725872a4624b35be50e2022fec06b1d77d58227fc9 SHA512 d34a63263f073c8fe6d61f105b753468d856de965b605c54ae4e8931bcb81293378f501b796cf84938857f7e08288f4650299cd76d56483f552846fc4b93b2b9
DIST intel-compute-runtime-22.18.23063.tar.gz 5355944 BLAKE2B ee4d79370c10f2aa1fcd0209a1403a89da1ff5a21dd8b39fb40ac33416b1adaef08713382ee89ad88e64b74d5edcb02e3877898e2301b5454a14b8910ebde009 SHA512 a94a3a7c331ea8bb059740ffaec6e139c17216be23c86cc9e880d247ff12dcb93357ee90b9863b9ddcea59dc1a3d377b32600675a145c29f12c810c13a9e3a61
DIST intel-compute-runtime-22.19.23136.tar.gz 5390779 BLAKE2B 376f355802d20ba76f485dcd174bb7dd0fa128495be37718b7eda3a3a2ef34086ef9060911f52866c1d1a4fd13f59115d511b5c6b327ce574ae494506085a91d SHA512 dc0c2f150b06c2a41a0d20c1ebcf38254d7ff976eef4340bcc3d47eab8e2ec0e36d8cc871b97ca4d8b304be53b0aced6b2a6fb66da7e58b0352297e7f28b81bf
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789-r3.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789-r3.ebuild
deleted file mode 100644
index 1f1a1ffad129..000000000000
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.13.22789-r3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-MY_PN="${PN/intel-/}"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+l0 +vaapi"
-
-RDEPEND=">=media-libs/gmmlib-22.0.2:="
-
-DEPEND="
- ${DEPEND}
- dev-libs/intel-metrics-library:=
- dev-libs/libnl:3
- dev-libs/libxml2:2
- >=dev-util/intel-graphics-compiler-1.0.10713
- >=dev-util/intel-graphics-system-controller-0.2.4:=
- media-libs/mesa
- >=virtual/opencl-3
- l0? ( >=dev-libs/level-zero-1.7.15 )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- x11-libs/libva
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "README.md" "FAQ.md" )
-
-src_configure() {
- # See https://github.com/intel/compute-runtime/issues/531
- filter-flags -flto=* -flto
-
- local mycmakeargs=(
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
- -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
- -DBUILD_WITH_L0="$(usex l0)"
- -DDISABLE_LIBVA="$(usex !vaapi)"
- -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
- -DSUPPORT_DG1="ON"
- -Wno-dev
-
- # See https://github.com/intel/intel-graphics-compiler/issues/204
- # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DSKIP_UNIT_TESTS="1"
- )
-
- cmake_src_configure
-}
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992-r3.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992-r3.ebuild
deleted file mode 100644
index c4452c450397..000000000000
--- a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.16.22992-r3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_BUILD_TYPE="Release"
-MY_PN="${PN/intel-/}"
-MY_P="${MY_PN}-${PV}"
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
-HOMEPAGE="https://github.com/intel/compute-runtime"
-SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="+l0 +vaapi"
-
-RDEPEND=">=media-libs/gmmlib-22.0.2:="
-
-DEPEND="
- ${DEPEND}
- dev-libs/intel-metrics-library:=
- dev-libs/libnl:3
- dev-libs/libxml2:2
- >=dev-util/intel-graphics-compiler-1.0.10713
- >=dev-util/intel-graphics-system-controller-0.2.4:=
- media-libs/mesa
- >=virtual/opencl-3
- l0? ( >=dev-libs/level-zero-1.7.15 )
- vaapi? (
- x11-libs/libdrm[video_cards_intel]
- x11-libs/libva
- )
-"
-
-BDEPEND="virtual/pkgconfig"
-
-DOCS=( "README.md" "FAQ.md" )
-
-src_configure() {
- # See https://github.com/intel/compute-runtime/issues/531
- filter-flags -flto=* -flto
-
- local mycmakeargs=(
- -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
- -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
- -DBUILD_WITH_L0="$(usex l0)"
- -DDISABLE_LIBVA="$(usex !vaapi)"
- -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
- -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
- -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
- -DSUPPORT_DG1="ON"
- -Wno-dev
-
- # See https://github.com/intel/intel-graphics-compiler/issues/204
- # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
-
- # If enabled, tests are automatically run during
- # the compile phase and we cannot run them because
- # they require permissions to access the hardware.
- -DSKIP_UNIT_TESTS="1"
- )
-
- cmake_src_configure
-}