summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/libgweather-40.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-libs/libgweather/libgweather-40.0.ebuild b/dev-libs/libgweather/libgweather-40.0.ebuild
index a9e1c0918c24..25aefdc8fd5d 100644
--- a/dev-libs/libgweather/libgweather-40.0.ebuild
+++ b/dev-libs/libgweather/libgweather-40.0.ebuild
@@ -37,6 +37,7 @@ BDEPEND="
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
$(vala_depend)
"
@@ -46,6 +47,10 @@ PATCHES=(
"${FILESDIR}"/40.0-autoskip-network-test.patch
)
+python_check_deps() {
+ has_version -b "dev-python/pygobject[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
python-any-r1_pkg_setup
}