summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libstrl/libstrl-0.5.1-r2.ebuild (renamed from dev-libs/libstrl/libstrl-0.5.1-r1.ebuild)26
1 files changed, 14 insertions, 12 deletions
diff --git a/dev-libs/libstrl/libstrl-0.5.1-r1.ebuild b/dev-libs/libstrl/libstrl-0.5.1-r2.ebuild
index 33b911319375..13faa3a50256 100644
--- a/dev-libs/libstrl/libstrl-0.5.1-r1.ebuild
+++ b/dev-libs/libstrl/libstrl-0.5.1-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit toolchain-funcs multilib-minimal
+EAPI=8
+
+inherit toolchain-funcs
DESCRIPTION="Compat library for functions like strlcpy(), strlcat(), strnlen(), getline()"
HOMEPAGE="http://ohnopub.net/~ohnobinki/libstrl/"
@@ -11,23 +12,24 @@ SRC_URI="http://mirror.ohnopub.net/mirror/${P}.tar.bz2"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x64-macos"
-IUSE="doc static-libs test"
+IUSE="doc test"
RESTRICT="!test? ( test )"
-DEPEND="
+BDEPEND="
doc? ( app-doc/doxygen )
test? ( dev-libs/check )
"
-src_prepare() {
- default
- multilib_copy_sources
-}
-
-multilib_src_configure() {
+src_configure() {
tc-export AR
+
econf \
- $(use_enable static-libs static) \
$(use_with doc doxygen) \
$(use_with test check)
}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}