summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-expat/Manifest1
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-1.1.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/ocaml-expat/Manifest b/dev-ml/ocaml-expat/Manifest
index 92f0567d8907..bafa5b14e824 100644
--- a/dev-ml/ocaml-expat/Manifest
+++ b/dev-ml/ocaml-expat/Manifest
@@ -1 +1,2 @@
DIST ocaml-expat-1.0.0.tar.gz 58149 SHA256 69d0bc2bfef2b4310faac2bb984173a26abde5c5758152822f6807774c7abe4f SHA512 217d602ac8fabf7713dcd8fd274206b81ff467402a9bca5b15b13f3b1d68e8e5f2c2970adeafb2378c0993b39c7d98a420dee07f30ad9eb88fd40665a2f98897 WHIRLPOOL 7f3140317bfb44a2980199a4cd09ca641dcfea419317289d1528402afdaa54c1f8bcff02053ad6cebf169441ae6c2ff0906ec7b3772bc3fe7c30cd588d86c445
+DIST ocaml-expat-1.1.0.tar.gz 58318 SHA256 1f23e3a355182ff93f43a90c1262865339fe29778825e990ca0337050ef9f616 SHA512 9407f91f5007d6835643719294d4e4907bfc40464d054911591ce80c31d173ddcc7b06157a19c0d3ddd78775806242dc68aea7847e588ca9fd1909def1df4d23 WHIRLPOOL 6bc42fe2d457a1798b463159ed8d61ee66888e5544ebe9393da30d6a2daa70fdac4280f7ef7882d95fc87b7061fdc3d15c508248fdf76d69e3c403ff0d360a2d
diff --git a/dev-ml/ocaml-expat/ocaml-expat-1.1.0.ebuild b/dev-ml/ocaml-expat/ocaml-expat-1.1.0.ebuild
new file mode 100644
index 000000000000..00eeb198ef8d
--- /dev/null
+++ b/dev-ml/ocaml-expat/ocaml-expat-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc +ocamlopt test"
+
+DESCRIPTION="OCaml bindings for expat"
+SRC_URI="https://github.com/whitequark/ocaml-expat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/whitequark/ocaml-expat"
+
+RDEPEND="dev-libs/expat
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+SLOT="0/${PV}"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+src_compile() {
+ emake depend
+ emake all
+ if use ocamlopt; then
+ emake allopt
+ fi
+}
+
+src_test() {
+ emake test
+ if use ocamlopt; then
+ emake testopt
+ fi
+}
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc ; then
+ dohtml -r doc/html/*
+ fi
+ dodoc README
+}