summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-stomp')
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-1.0.9-r1.ebuild10
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild13
2 files changed, 13 insertions, 10 deletions
diff --git a/dev-php/pecl-stomp/pecl-stomp-1.0.9-r1.ebuild b/dev-php/pecl-stomp/pecl-stomp-1.0.9-r1.ebuild
index 8349a99f9a6c..d8aef480451f 100644
--- a/dev-php/pecl-stomp/pecl-stomp-1.0.9-r1.ebuild
+++ b/dev-php/pecl-stomp/pecl-stomp-1.0.9-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_PHP="php5-6 php7-0"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
PHP_EXT_NAME="stomp"
DOCS=( CREDITS doc/classes.php doc/functions.php )
@@ -23,7 +23,11 @@ DEPEND="${DEPEND}
"
RDEPEND="${DEPEND}"
-PDEPEND="php_targets_php7-0? ( dev-php/pecl-stomp:7 )"
+PDEPEND="
+ php_targets_php7-1? ( dev-php/pecl-stomp:7 )
+ php_targets_php7-2? ( dev-php/pecl-stomp:7 )
+ php_targets_php7-3? ( dev-php/pecl-stomp:7 )
+"
src_prepare() {
if use php_targets_php5-6 ; then
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
index a4649795c926..d808c2c1b917 100644
--- a/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.2.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
PHP_EXT_NAME="stomp"
DOCS=( CREDITS doc/classes.php doc/functions.php )
inherit php-ext-pecl-r3
-USE_PHP="php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php7-1 php7-2 php7-3"
KEYWORDS="~amd64 ~x86"
@@ -19,7 +19,6 @@ SLOT="7"
IUSE="examples ssl test"
DEPEND="${DEPEND}
- php_targets_php7-0? ( dev-lang/php:7.0[ssl?] )
php_targets_php7-1? ( dev-lang/php:7.1[ssl?] )
php_targets_php7-2? ( dev-lang/php:7.2[ssl?] )
php_targets_php7-3? ( dev-lang/php:7.3[ssl?] )
@@ -29,7 +28,7 @@ RDEPEND="${DEPEND}
php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-source-r3_src_prepare
else
default
@@ -37,7 +36,7 @@ src_prepare() {
}
src_configure() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7_2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
local PHP_EXT_ECONF_ARGS=(
--enable-stomp
--with-openssl-dir=$(usex ssl "${EPREFIX}/usr")
@@ -47,7 +46,7 @@ src_configure() {
}
src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7_2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
php-ext-pecl-r3_src_install
fi
}