summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/awscli/awscli-1.16.72.ebuild')
-rw-r--r--dev-python/awscli/awscli-1.16.72.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/awscli/awscli-1.16.72.ebuild b/dev-python/awscli/awscli-1.16.72.ebuild
deleted file mode 100644
index 1a34c9d79e7a..000000000000
--- a/dev-python/awscli/awscli-1.16.72.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Universal Command Line Environment for AWS"
-HOMEPAGE="https://pypi.org/project/awscli/"
-#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/aws/aws-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-# requires network access
-RESTRICT="test"
-
-RDEPEND="
- >=dev-python/botocore-1.12[${PYTHON_USEDEP}]
- <=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- <=dev-python/rsa-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/s3transfer-0.1.12[${PYTHON_USEDEP}]
- <=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/aws-cli-${PV}"
-
-python_test() {
- nosetests -vv || die
-}