summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/Manifest1
-rw-r--r--dev-python/clang-python/clang-python-5.0.0.ebuild45
2 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/clang-python/Manifest b/dev-python/clang-python/Manifest
index c1961aa671cf..47974bf00682 100644
--- a/dev-python/clang-python/Manifest
+++ b/dev-python/clang-python/Manifest
@@ -1,3 +1,2 @@
DIST cfe-4.0.1.src.tar.xz 10933628 BLAKE2B bc1bb8875e83ccecd446a48cfa41f5c98a09d6ad24ff439a983f629711b4513b9c4bee4070f8df13b6b2a52d673b0706733a4c151ce5021a0233147debff14ac SHA512 936c9e1626b27e63a4fb11f3c0cb998eeaf9a520ad6e2bcd67cb4352e59e7781ecc700df79794f3fd70473d90b7e2ba418a39038eb0146b68e843f0705c1f964
-DIST cfe-5.0.0.src.tar.xz 11437024 BLAKE2B c848d9771951be4d5fb14d5ca3a0ad788675c0833bd4f2e2069475d64e6108297bb2dbae5129b516d35b6a8c51c020afec430fcf32058970455060e50442a73f SHA512 14acdd622310122b544c952ee5b932b7006d9d8424319f0e3974f2503d40a0cec4200fdd3d813a32ce0d877bcfbb9a5bd5c36f6142b4330e6c814f113ca2efe8
DIST cfe-5.0.1.src.tar.xz 11483036 BLAKE2B c4eb54cd8271b62cf7a2219db0b599b68c00b6e574d1946220efbd1633e841796e6717d6eeb35e84a6db32a731a3285b59cedeb3b1a8f3c3c502b799fdd0a720 SHA512 6619177a2ff9934fe8b15d6aa229abb8e34d0b1a75228d9efba9393daf71d6419a7256de57b31e2f9f829f71f842118556f996e86ee076f1e0a7cd394dfd31a2
diff --git a/dev-python/clang-python/clang-python-5.0.0.ebuild b/dev-python/clang-python/clang-python-5.0.0.ebuild
deleted file mode 100644
index d652274a033e..000000000000
--- a/dev-python/clang-python/clang-python-5.0.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit python-r1
-
-DESCRIPTION="Python bindings for sys-devel/clang"
-HOMEPAGE="https://llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV/_//}/cfe-${PV/_/}.src.tar.xz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# The module is opening libclang.so directly, and doing some blasphemy
-# on top of it.
-RDEPEND="
- >=sys-devel/clang-${PV}:*
- !sys-devel/llvm:0[clang(-),python(-)]
- !sys-devel/clang:0[python(-)]
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/cfe-${PV/_/}.src/bindings/python
-
-src_prepare() {
- default
-
- # move to the correct subdirectory
- # https://reviews.llvm.org/D37378
- mv tests/{,cindex/}test_exception_specification_kind.py || die
-}
-
-src_test() {
- python_foreach_impl nosetests -v || die
-}
-
-src_install() {
- python_foreach_impl python_domodule clang
-}