summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cligj/cligj-0.4.0.ebuild')
-rw-r--r--dev-python/cligj/cligj-0.4.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/cligj/cligj-0.4.0.ebuild b/dev-python/cligj/cligj-0.4.0.ebuild
new file mode 100644
index 000000000000..9ccb035f27d1
--- /dev/null
+++ b/dev-python/cligj/cligj-0.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Click-based argument and option decorators for Python GIS command line programs"
+HOMEPAGE="https://github.com/mapbox/cligj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"