summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dbfread')
-rw-r--r--dev-python/dbfread/Manifest1
-rw-r--r--dev-python/dbfread/dbfread-2.0.7.ebuild25
2 files changed, 25 insertions, 1 deletions
diff --git a/dev-python/dbfread/Manifest b/dev-python/dbfread/Manifest
index f6f5ebe70b1f..0d551756ca38 100644
--- a/dev-python/dbfread/Manifest
+++ b/dev-python/dbfread/Manifest
@@ -1 +1,2 @@
+DIST dbfread-2.0.7-src.tar.gz 33045 BLAKE2B 96798f00aba4c30e7e83b468f368ca6730a7e095c9fec5bf5515ac6a152022adbf5339cd9e68e85f4eccac211ed4e307b9abf22249ef6420d722fa213210d7d7 SHA512 cf591fa5800e5471025175a4bbbb54cb26dc2a83bf328776e4386860370d9421edd9edd62cb9e3d463794d526c561a0f4744bb67b5e376edd471dc95100bc2c7
DIST dbfread-2.0.7.tar.gz 33212 BLAKE2B 03c9a0d93b13c7573b5bcec6c5af1ac43bd00ead2b3e83638f45344b2344062e86d764b095e699afdaea2405176ee15122c975a2f72b25bd167f5faaaf33043b SHA512 86c3a29e351b985984be67401a6dfe3e39cd92451a122788ade83d65313dde37a3706ce36c4365bd36ba1df62ee057b625f1e0f077aa4a248c7456258189f548
diff --git a/dev-python/dbfread/dbfread-2.0.7.ebuild b/dev-python/dbfread/dbfread-2.0.7.ebuild
index f9a2f5858661..a2df96057106 100644
--- a/dev-python/dbfread/dbfread-2.0.7.ebuild
+++ b/dev-python/dbfread/dbfread-2.0.7.ebuild
@@ -9,9 +9,32 @@ inherit distutils-r1
DESCRIPTION="Read DBF Files with Python"
HOMEPAGE="https://github.com/olemb/dbfread https://pypi.org/project/dbfread/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ test? ( https://github.com/olemb/dbfread/archive/refs/tags/${PV}.tar.gz -> ${P}-src.tar.gz )"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
RDEPEND=""
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's|\[pytest\]|[tool:pytest]|' -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local pytest_args test_name xfails
+
+ xfails=(
+ dbfread/test_read_and_length.py::test_len
+ dbfread/test_read_and_length.py::test_list
+ )
+
+ for test_name in "${xfails[@]}"; do
+ pytest_args+=(--deselect "${test_name}")
+ done
+
+ epytest "${pytest_args[@]}" || die
+}