summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jq')
-rw-r--r--dev-python/jq/Manifest1
-rw-r--r--dev-python/jq/jq-1.4.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/jq/Manifest b/dev-python/jq/Manifest
index 24c9a0106170..3be69fe725f8 100644
--- a/dev-python/jq/Manifest
+++ b/dev-python/jq/Manifest
@@ -1 +1,2 @@
DIST jq.py-1.4.0.gh.tar.gz 2648402 BLAKE2B 5efc35fd9ee52e5c1c87ac46d980d1557121eedb14beb5d534987d81a37b05c5c765ef69cecf65141d7c451623d05d378bdcf9a6e48667c07a9f52e7d0317bbf SHA512 8acd9c4094e0e6f5ffd43303432347448e8cb160f2c33250a386afc75eac53134b15142da3f344b0ea3eac4df838ffa322771580a27349299f32a2c525e09555
+DIST jq.py-1.4.1.gh.tar.gz 2648592 BLAKE2B b1413a07ba03f61d3b2e8cfa3f2c646408e24139f76fb9637d23968d953fa78f82b1dd04c355d5a6e6c6761095a4814d8cfd1f012382ca810ad5a44e007c7878 SHA512 03924793e8cab8041b4b2ecb8ef45bafdf31f14b4502170358ddecc027ead7cc17eda37fc04743eeef073e29144d2f7e6c4428e2a92f1bb8aa859100dce4521b
diff --git a/dev-python/jq/jq-1.4.1.ebuild b/dev-python/jq/jq-1.4.1.ebuild
new file mode 100644
index 000000000000..417b5256add9
--- /dev/null
+++ b/dev-python/jq/jq-1.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P="jq.py-${PV}"
+DESCRIPTION="Python bindings for jq"
+HOMEPAGE="
+ https://github.com/mwilliamson/jq.py/
+ https://pypi.org/project/jq/
+"
+SRC_URI="
+ https://github.com/mwilliamson/jq.py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ # Cython compilation isn't part of setup.py, so do it manually
+ "${EPYTHON}" -m cython -3 jq.pyx -o jq.c || die
+ distutils-r1_python_compile
+}