summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vecrec')
-rw-r--r--dev-python/vecrec/vecrec-0.3.0.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-python/vecrec/vecrec-0.3.0.ebuild b/dev-python/vecrec/vecrec-0.3.0.ebuild
index 39e023068ff1..b0729371a7bd 100644
--- a/dev-python/vecrec/vecrec-0.3.0.ebuild
+++ b/dev-python/vecrec/vecrec-0.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -11,13 +11,13 @@ DESCRIPTION="2D vector and rectangle classes"
HOMEPAGE="https://github.com/kxgames/vecrec
https://pypi.org/project/vecrec/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-LICENSE="MIT"
+LICENSE="MIT"
KEYWORDS="~amd64"
SLOT="0"
distutils_enable_tests pytest
python_test() {
- pytest -vv tests || die "Tests fail with ${EPYTHON}"
+ epytest tests
}