summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/strace/strace-9999.ebuild')
-rw-r--r--dev-util/strace/strace-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index 6c5ede46696d..df019fe92aa1 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -3,7 +3,7 @@
EAPI="5"
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.code.sf.net/p/strace/code"
@@ -48,6 +48,14 @@ src_prepare() {
}
src_configure() {
+ # Set up the default build settings, and then use the naems strace expects.
+ tc-export_build_env BUILD_{CC,CPP}
+ local v bv
+ for v in CC CPP {C,CPP,LD}FLAGS ; do
+ bv="BUILD_${v}"
+ export "${v}_FOR_BUILD=${!bv}"
+ done
+
econf $(use_with unwind libunwind)
}