summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/melonds-jg/melonds-jg-0.9.5.ebuild10
-rw-r--r--games-emulation/melonds-jg/melonds-jg-9999.ebuild10
2 files changed, 18 insertions, 2 deletions
diff --git a/games-emulation/melonds-jg/melonds-jg-0.9.5.ebuild b/games-emulation/melonds-jg/melonds-jg-0.9.5.ebuild
index a927283b5272..e85a48508359 100644
--- a/games-emulation/melonds-jg/melonds-jg-0.9.5.ebuild
+++ b/games-emulation/melonds-jg/melonds-jg-0.9.5.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
MY_PN=${PN%-*}
MY_P=${MY_PN}-${PV}
@@ -40,6 +40,14 @@ PATCHES=(
)
src_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/931907
+ #
+ # Not trivial to fix and its a problem in melonds upstream.
+ # Its also uncertain if this port will be updated in the future.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
emake -C jollygood \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \
diff --git a/games-emulation/melonds-jg/melonds-jg-9999.ebuild b/games-emulation/melonds-jg/melonds-jg-9999.ebuild
index bc683935d9e5..af1f24fc344a 100644
--- a/games-emulation/melonds-jg/melonds-jg-9999.ebuild
+++ b/games-emulation/melonds-jg/melonds-jg-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit toolchain-funcs flag-o-matic
MY_PN=${PN%-*}
MY_P=${MY_PN}-${PV}
@@ -34,6 +34,14 @@ BDEPEND="
"
src_compile() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/931907
+ #
+ # Not trivial to fix and its a problem in melonds upstream.
+ # Its also uncertain if this port will be updated in the future.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
emake -C jollygood \
CC="$(tc-getCC)" \
CXX="$(tc-getCXX)" \