summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/kcalc')
-rw-r--r--kde-apps/kcalc/files/kcalc-15.12.3-fixsetsize.patch15
-rw-r--r--kde-apps/kcalc/kcalc-15.12.3-r1.ebuild38
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-apps/kcalc/files/kcalc-15.12.3-fixsetsize.patch b/kde-apps/kcalc/files/kcalc-15.12.3-fixsetsize.patch
new file mode 100644
index 000000000000..a2ff272a47cb
--- /dev/null
+++ b/kde-apps/kcalc/files/kcalc-15.12.3-fixsetsize.patch
@@ -0,0 +1,15 @@
+Fix issue where kcalc has a zero-sized window and appears not to start.
+
+Patch-by: Rex Dieter <rdieter@math.unl.edu>
+Gentoo-bug: 577782
+KDE-bug: 360105
+
+--- a/kcalc.cpp
++++ b/kcalc.cpp
+@@ -124,5 +124,5 @@ KCalculator::KCalculator(QWidget *parent
+ updateGeometry();
+
+- setFixedSize(minimumSize());
++ if ( ! minimumSize().isEmpty() ) setFixedSize(minimumSize());
+
+ updateDisplay(UPDATE_FROM_CORE);
diff --git a/kde-apps/kcalc/kcalc-15.12.3-r1.ebuild b/kde-apps/kcalc/kcalc-15.12.3-r1.ebuild
new file mode 100644
index 000000000000..47e3b424b19b
--- /dev/null
+++ b/kde-apps/kcalc/kcalc-15.12.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_DOXYGEN="true"
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE calculator"
+HOMEPAGE="https://www.kde.org/applications/utilities/kcalc
+https://utils.kde.org/projects/kcalc"
+KEYWORDS=" ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ dev-libs/gmp:0=
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep kinit)
+ dev-libs/mpfr:0
+ sys-devel/gettext
+"
+
+PATCHES=( "${FILESDIR}/${P}-fixsetsize.patch" )