summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/ktouch/files/ktouch-16.12.0-deps.patch')
-rw-r--r--kde-apps/ktouch/files/ktouch-16.12.0-deps.patch78
1 files changed, 78 insertions, 0 deletions
diff --git a/kde-apps/ktouch/files/ktouch-16.12.0-deps.patch b/kde-apps/ktouch/files/ktouch-16.12.0-deps.patch
new file mode 100644
index 000000000000..2dbfe7607396
--- /dev/null
+++ b/kde-apps/ktouch/files/ktouch-16.12.0-deps.patch
@@ -0,0 +1,78 @@
+commit 6bc9417c81e1c5792da313fb15b4e0b222f2d7ca
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Mon Dec 19 20:47:50 2016 +0100
+
+ Fix and sort dependencies
+
+ REVIEW: 129676
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7a0099c..3175453 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,32 +25,32 @@ include(ECMSetupVersion)
+ include(FeatureSummary)
+
+ find_package(Qt5 5.5 REQUIRED COMPONENTS
+- Widgets
+- Sql
+- Script
+- XmlPatterns
++ Gui
+ Qml
+ Quick
+ QuickWidgets
++ Script
++ Sql
+ Test
++ Widgets
+ X11Extras
++ Xml
++ XmlPatterns
+ )
+
+ find_package(KF5 REQUIRED COMPONENTS
++ Completion
+ Config
+ ConfigWidgets
+ CoreAddons
+ Declarative
+ DocTools
+ I18n
+- KIO
+- NewStuff
+- WidgetsAddons
+- XmlGui
+ ItemViews
+ KCMUtils
+- TextEditor
+- WindowSystem
++ TextWidgets
++ WidgetsAddons
++ XmlGui
+ )
+
+ # subdirectories to build
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 6633f35..1003a0b 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -131,16 +131,14 @@ target_link_libraries(ktouch
+ Qt5::Sql
+ Qt5::XmlPatterns
+ Qt5::X11Extras
++ KF5::Completion
+ KF5::ConfigWidgets
+ KF5::Declarative
+- KF5::KIOWidgets
+ KF5::ItemViews
+- KF5::NewStuff
+ KF5::XmlGui
+ KF5::I18n
+ KF5::KCMUtils
+- KF5::TextEditor
+- KF5::WindowSystem
++ KF5::TextWidgets
+ KF5::CoreAddons
+ ${ktouch_X11_DEPS}
+ )