summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wol/wol-0.7.1-r3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-misc/wol/wol-0.7.1-r3.ebuild b/net-misc/wol/wol-0.7.1-r3.ebuild
new file mode 100644
index 000000000000..4b4ba0165cd9
--- /dev/null
+++ b/net-misc/wol/wol-0.7.1-r3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Implements Wake On LAN (Magic Paket) functionality in a small program"
+HOMEPAGE="http://ahh.sourceforge.net/wol/"
+SRC_URI="mirror://sourceforge/ahh/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86"
+IUSE="nls"
+
+PATCHES=( "${FILESDIR}/${P}-musl.patch" )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable nls)
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}