summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-6.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index db3779133156..c3c45bc9e537 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -1,2 +1,3 @@
DIST ethtool-5.15.tar.xz 318864 BLAKE2B 855c07e388bfabf37637f20e2714c6ca27717f38d7f658be96e0e9ec9d4514e61f4ee29361fc0279510869606ad18126ccd2a47160f1097ab52b1e35216e9721 SHA512 28147468a92c179217b459907a3257ee4f2d2ed028cb87b074f1c7ca6eb91aca81c8a9f5c7fe74e81d16a516e6e7eb20137bf7a15b5479fd82a327c64954da12
DIST ethtool-5.19.tar.xz 324472 BLAKE2B 44cc292db04f411a57a0a5ae0cdfbef733c7ee739fc252523c713489a13ae33de3927b500db796bc584fef3c83d7238dca2af4e6b6a5c594bbf21e87ed2380a7 SHA512 71103c6856a889161ef2bf81eadec69b2f3a84c94aa776d545f889dc1c55b91d566d3b7394dbd2cb70ed92ac19d5f26967b1f829c204f23831d1fb81a0464972
+DIST ethtool-6.1.tar.xz 327644 BLAKE2B 002a4edffda42520d77e8f0c27adf909090823f1a08689b67fc7c75de3048bdc9c94d7d32973bd17562d7dbf295479e796c2529b5db66b5fce42a2ede5851cd6 SHA512 6ca478ec75dae7cc347b859802e1965e6c78310ec4b276dec29bdf76d3464e4186c6e5ed0cb8f013171d6c0562c1156cb0442419f5b947c314e8b91ad9fd2d93
diff --git a/sys-apps/ethtool/ethtool-6.1.ebuild b/sys-apps/ethtool/ethtool-6.1.ebuild
new file mode 100644
index 000000000000..8d122a733c09
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-6.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}