summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/wdm')
-rw-r--r--x11-misc/wdm/wdm-1.28-r6.ebuild (renamed from x11-misc/wdm/wdm-1.28-r4.ebuild)7
-rw-r--r--x11-misc/wdm/wdm-1.28-r7.ebuild (renamed from x11-misc/wdm/wdm-1.28-r5.ebuild)7
2 files changed, 10 insertions, 4 deletions
diff --git a/x11-misc/wdm/wdm-1.28-r4.ebuild b/x11-misc/wdm/wdm-1.28-r6.ebuild
index f6b3385ca80a..1ba2a83d76c2 100644
--- a/x11-misc/wdm/wdm-1.28-r4.ebuild
+++ b/x11-misc/wdm/wdm-1.28-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -41,5 +41,8 @@ src_install() {
default
rm -f "${ED%/}"/etc/pam.d/wdm || die
- pamd_mimic system-local-login wdm auth account password session
+
+ if use pam; then
+ pamd_mimic system-local-login wdm auth account password session
+ fi
}
diff --git a/x11-misc/wdm/wdm-1.28-r5.ebuild b/x11-misc/wdm/wdm-1.28-r7.ebuild
index 797dafa1bf98..d94c24004807 100644
--- a/x11-misc/wdm/wdm-1.28-r5.ebuild
+++ b/x11-misc/wdm/wdm-1.28-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -53,5 +53,8 @@ src_install() {
default
rm -f "${ED}"/etc/pam.d/wdm || die
- pamd_mimic system-local-login wdm auth account password session
+
+ if use pam; then
+ pamd_mimic system-local-login wdm auth account password session
+ fi
}