summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/awesome/files')
-rw-r--r--x11-wm/awesome/files/awesome-4.0-cflag-cleanup.patch11
-rw-r--r--x11-wm/awesome/files/awesome-4.0-convert-path.patch11
2 files changed, 22 insertions, 0 deletions
diff --git a/x11-wm/awesome/files/awesome-4.0-cflag-cleanup.patch b/x11-wm/awesome/files/awesome-4.0-cflag-cleanup.patch
new file mode 100644
index 000000000000..4b8379437c15
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-4.0-cflag-cleanup.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -98,7 +98,7 @@
+
+ # CFLAGS
+ set(AWESOME_C_FLAGS
+- -O1 -std=gnu99 -ggdb3 -fno-strict-aliasing -Wall -Wextra
++ -std=gnu99 -fno-strict-aliasing -Wall -Wextra
+ -Wchar-subscripts -Wundef -Wshadow -Wcast-align -Wwrite-strings
+ -Wsign-compare -Wunused -Wno-unused-parameter -Wuninitialized -Winit-self
+ -Wpointer-arith -Wformat-nonliteral
diff --git a/x11-wm/awesome/files/awesome-4.0-convert-path.patch b/x11-wm/awesome/files/awesome-4.0-convert-path.patch
new file mode 100644
index 000000000000..1eabf0923afc
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-4.0-convert-path.patch
@@ -0,0 +1,11 @@
+--- a/awesomeConfig.cmake
++++ b/awesomeConfig.cmake
+@@ -51,7 +51,7 @@
+ endif()
+ endif()
+ # theme graphics
+-a_find_program(CONVERT_EXECUTABLE convert TRUE)
++a_find_program(CONVERT_EXECUTABLE bin/convert TRUE)
+ # pkg-config
+ include(FindPkgConfig)
+ # lua