summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/garcon/garcon-0.7.3.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/xfce-base/garcon/garcon-0.7.3.ebuild b/xfce-base/garcon/garcon-0.7.3.ebuild
index 1f205f520f8f..6433ea9ccb51 100644
--- a/xfce-base/garcon/garcon-0.7.3.ebuild
+++ b/xfce-base/garcon/garcon-0.7.3.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit xdg-utils
+
DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
HOMEPAGE="https://docs.xfce.org/xfce/exo/start"
SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
@@ -39,3 +41,11 @@ src_install() {
find "${D}" -name '*.la' -delete || die
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}