From 2da114edf6cb70c8e2a05a1e337330144abd21ad Mon Sep 17 00:00:00 2001
From: Christopher Fore <csfore@posteo.net>
Date: Fri, 5 Jan 2024 19:06:11 -0500
Subject: app-crypt/mhash: fix compilation on GCC 14

Closes: https://bugs.gentoo.org/919700
Closes: https://github.com/gentoo/gentoo/pull/34665
Signed-off-by: Christopher Fore <csfore@posteo.net>
Signed-off-by: Yixun Lan <dlan@gentoo.org>
---
 app-crypt/mhash/files/mhash-0.9.9.9-cast-temp-64bit.patch | 13 +++++++++++++
 app-crypt/mhash/mhash-0.9.9.9-r3.ebuild                   |  3 ++-
 2 files changed, 15 insertions(+), 1 deletion(-)
 create mode 100644 app-crypt/mhash/files/mhash-0.9.9.9-cast-temp-64bit.patch

diff --git a/app-crypt/mhash/files/mhash-0.9.9.9-cast-temp-64bit.patch b/app-crypt/mhash/files/mhash-0.9.9.9-cast-temp-64bit.patch
new file mode 100644
index 000000000000..3b173f8072cb
--- /dev/null
+++ b/app-crypt/mhash/files/mhash-0.9.9.9-cast-temp-64bit.patch
@@ -0,0 +1,13 @@
+diff --git a/lib/tiger.c b/lib/tiger.c
+index 8f15df4..8d28f27 100644
+--- a/lib/tiger.c
++++ b/lib/tiger.c
+@@ -254,7 +254,7 @@ void tiger_final(struct tiger_ctx *ctx)
+ 	register mutils_word64 i, j;
+ 	/* Force 64-bit alignment */
+ 	mutils_word64 temp_64bit[TIGER_DATASIZE/8];
+-	mutils_word8 *temp = temp_64bit;
++	mutils_word8 *temp = (mutils_word8 *) temp_64bit;
+ 	i = ctx->index;
+ 	
+ #if defined(WORDS_BIGENDIAN)
diff --git a/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild b/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
index 59e8dcb9010e..092842a0b701 100644
--- a/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
+++ b/app-crypt/mhash/mhash-0.9.9.9-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=8
@@ -27,6 +27,7 @@ PATCHES=(
 	"${FILESDIR}"/${P}-alignment.patch
 	"${FILESDIR}"/${P}-no-malloc-check.patch
 	"${FILESDIR}"/${P}-hmac-uaf-test.patch
+	"${FILESDIR}"/${P}-cast-temp-64bit.patch
 )
 
 DOCS=( doc/example.c doc/skid2-authentication )
-- 
cgit v1.2.3-65-gdbad