From 979165f382c76a9728c16ec4b1ac672a2799a809 Mon Sep 17 00:00:00 2001
From: Amadeusz Żołnowski <aidecoe@gentoo.org>
Date: Sat, 9 Jul 2016 19:01:18 +0100
Subject: dev-erlang/hamcrest: Change patch name

Package-Manager: portage-2.3.0
---
 .../files/0.1.0_p20150103-0001-Fix-unittests.patch | 88 ++++++++++++++++++++++
 .../0.1.0_p20150103-0001-OTP-19-support.patch      | 88 ----------------------
 .../hamcrest/hamcrest-0.1.0_p20150103.ebuild       |  2 +-
 3 files changed, 89 insertions(+), 89 deletions(-)
 create mode 100644 dev-erlang/hamcrest/files/0.1.0_p20150103-0001-Fix-unittests.patch
 delete mode 100644 dev-erlang/hamcrest/files/0.1.0_p20150103-0001-OTP-19-support.patch

(limited to 'dev-erlang')

diff --git a/dev-erlang/hamcrest/files/0.1.0_p20150103-0001-Fix-unittests.patch b/dev-erlang/hamcrest/files/0.1.0_p20150103-0001-Fix-unittests.patch
new file mode 100644
index 000000000000..94e507cf66ce
--- /dev/null
+++ b/dev-erlang/hamcrest/files/0.1.0_p20150103-0001-Fix-unittests.patch
@@ -0,0 +1,88 @@
+From 4eb8b813d0086a6eca9627ab64721378b07aa030 Mon Sep 17 00:00:00 2001
+From: Luke Bakken <lbakken@basho.com>
+Date: Sat, 9 Jul 2016 07:43:41 -0700
+Subject: [PATCH] OTP 19 support via compilation of CT suite. This defines
+ namespaced_types. Disable CT auto-compile. Fix warnings. Update to proper
+ v1.2
+
+---
+ .gitignore                       |  8 ++++++++
+ test.config                      | 16 +++++++++++++---
+ test/hamcrest_matchers_SUITE.erl |  4 ++--
+ 3 files changed, 23 insertions(+), 5 deletions(-)
+
+diff --git a/.gitignore b/.gitignore
+index 59ac5eb..d6882d0 100755
+--- a/.gitignore
++++ b/.gitignore
+@@ -4,6 +4,7 @@
+ *.o
+ *.so
+ *.swp
++.rebar/
+ build/*
+ ^build$
+ Emakefile
+@@ -15,3 +16,10 @@ ebin/*.beam
+ logs/*
+ include/hamcrest.hrl
+ qc.hrl
++deps/
++ct_*/
++all_runs.html
++ct_*
++jquery-latest.js
++jquery.tablesorter.min.js
++variables-ct@localhost
+diff --git a/test.config b/test.config
+index bff1a63..f206e37 100644
+--- a/test.config
++++ b/test.config
+@@ -1,9 +1,19 @@
+-
+ {cover_enabled, true}.
++
+ {deps, [
+-    %% TODO: bind to a specific commit or tag instead of 'master'
+-    {proper, ".*", {git, "http://github.com/manopapad/proper.git", "v1.1"}}
++    {proper, "1.*", {git, "http://github.com/manopapad/proper.git", "v1.2"}}
+ ]}.
+ 
++{erl_opts, [
++    debug_info,
++    fail_on_warning,
++    {src_dirs, ["test"]},
++    {platform_define, "^[0-9]+", namespaced_types}
++    ]}.
++
++{validate_app_modules, false}.
++
++{ct_extra_params, "-no_auto_compile"}.
++
+ {plugin_dir, "priv/build/plugins"}.
+ {plugins, [eqc_resolver]}.
+diff --git a/test/hamcrest_matchers_SUITE.erl b/test/hamcrest_matchers_SUITE.erl
+index f2889e2..6726425 100644
+--- a/test/hamcrest_matchers_SUITE.erl
++++ b/test/hamcrest_matchers_SUITE.erl
+@@ -69,7 +69,7 @@ is_not_evaluates_to_logical_negation_of_underlying_matcher(_) ->
+     ?EQC(P).
+ 
+ is_not_provides_convenient_shortcut_for_not_equal_to(_) ->
+-    P = ?FORALL({X, Y}, {binary(), binary()},
++    P = ?FORALL({X, _Y}, {binary(), binary()},
+             begin
+                 #'hamcrest.matchspec'{matcher=F1} = equal_to(X),
+                 #'hamcrest.matchspec'{matcher=F2} = is_not(X),
+@@ -240,7 +240,7 @@ ends_with_should_only_match_last_portion_of_string(_) ->
+         ?IMPLIES(length(Xs) > 0,
+         begin
+           Y = round(length(Xs) / 2),
+-          LStr = string:left(Xs, Y),
++          _LStr = string:left(Xs, Y),
+           RStr = string:right(Xs, Y),
+           case (assert_that(Xs, ends_with(RStr))) of
+             true -> true;
+-- 
+2.9.0
+
diff --git a/dev-erlang/hamcrest/files/0.1.0_p20150103-0001-OTP-19-support.patch b/dev-erlang/hamcrest/files/0.1.0_p20150103-0001-OTP-19-support.patch
deleted file mode 100644
index 94e507cf66ce..000000000000
--- a/dev-erlang/hamcrest/files/0.1.0_p20150103-0001-OTP-19-support.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From 4eb8b813d0086a6eca9627ab64721378b07aa030 Mon Sep 17 00:00:00 2001
-From: Luke Bakken <lbakken@basho.com>
-Date: Sat, 9 Jul 2016 07:43:41 -0700
-Subject: [PATCH] OTP 19 support via compilation of CT suite. This defines
- namespaced_types. Disable CT auto-compile. Fix warnings. Update to proper
- v1.2
-
----
- .gitignore                       |  8 ++++++++
- test.config                      | 16 +++++++++++++---
- test/hamcrest_matchers_SUITE.erl |  4 ++--
- 3 files changed, 23 insertions(+), 5 deletions(-)
-
-diff --git a/.gitignore b/.gitignore
-index 59ac5eb..d6882d0 100755
---- a/.gitignore
-+++ b/.gitignore
-@@ -4,6 +4,7 @@
- *.o
- *.so
- *.swp
-+.rebar/
- build/*
- ^build$
- Emakefile
-@@ -15,3 +16,10 @@ ebin/*.beam
- logs/*
- include/hamcrest.hrl
- qc.hrl
-+deps/
-+ct_*/
-+all_runs.html
-+ct_*
-+jquery-latest.js
-+jquery.tablesorter.min.js
-+variables-ct@localhost
-diff --git a/test.config b/test.config
-index bff1a63..f206e37 100644
---- a/test.config
-+++ b/test.config
-@@ -1,9 +1,19 @@
--
- {cover_enabled, true}.
-+
- {deps, [
--    %% TODO: bind to a specific commit or tag instead of 'master'
--    {proper, ".*", {git, "http://github.com/manopapad/proper.git", "v1.1"}}
-+    {proper, "1.*", {git, "http://github.com/manopapad/proper.git", "v1.2"}}
- ]}.
- 
-+{erl_opts, [
-+    debug_info,
-+    fail_on_warning,
-+    {src_dirs, ["test"]},
-+    {platform_define, "^[0-9]+", namespaced_types}
-+    ]}.
-+
-+{validate_app_modules, false}.
-+
-+{ct_extra_params, "-no_auto_compile"}.
-+
- {plugin_dir, "priv/build/plugins"}.
- {plugins, [eqc_resolver]}.
-diff --git a/test/hamcrest_matchers_SUITE.erl b/test/hamcrest_matchers_SUITE.erl
-index f2889e2..6726425 100644
---- a/test/hamcrest_matchers_SUITE.erl
-+++ b/test/hamcrest_matchers_SUITE.erl
-@@ -69,7 +69,7 @@ is_not_evaluates_to_logical_negation_of_underlying_matcher(_) ->
-     ?EQC(P).
- 
- is_not_provides_convenient_shortcut_for_not_equal_to(_) ->
--    P = ?FORALL({X, Y}, {binary(), binary()},
-+    P = ?FORALL({X, _Y}, {binary(), binary()},
-             begin
-                 #'hamcrest.matchspec'{matcher=F1} = equal_to(X),
-                 #'hamcrest.matchspec'{matcher=F2} = is_not(X),
-@@ -240,7 +240,7 @@ ends_with_should_only_match_last_portion_of_string(_) ->
-         ?IMPLIES(length(Xs) > 0,
-         begin
-           Y = round(length(Xs) / 2),
--          LStr = string:left(Xs, Y),
-+          _LStr = string:left(Xs, Y),
-           RStr = string:right(Xs, Y),
-           case (assert_that(Xs, ends_with(RStr))) of
-             true -> true;
--- 
-2.9.0
-
diff --git a/dev-erlang/hamcrest/hamcrest-0.1.0_p20150103.ebuild b/dev-erlang/hamcrest/hamcrest-0.1.0_p20150103.ebuild
index 04bd458ea51f..787dff1c4866 100644
--- a/dev-erlang/hamcrest/hamcrest-0.1.0_p20150103.ebuild
+++ b/dev-erlang/hamcrest/hamcrest-0.1.0_p20150103.ebuild
@@ -22,7 +22,7 @@ DEPEND="${CDEPEND}
 RDEPEND="${CDEPEND}"
 
 DOCS=( NOTES  README.markdown TODO.md )
-PATCHES=( "${FILESDIR}"/${PV}-0001-OTP-19-support.patch )
+PATCHES=( "${FILESDIR}"/${PV}-0001-Fix-unittests.patch )
 
 # Override with EAPI default because it's missing hamcrest.app.src and doesn't
 # have any deps.
-- 
cgit v1.2.3-65-gdbad