From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 dev-libs/libRocket/Manifest                        |  2 +
 .../libRocket/files/libRocket-1.2.1-build.patch    | 44 ++++++++++
 .../libRocket/files/libRocket-1.3.0.0-build.patch  | 44 ++++++++++
 .../libRocket/libRocket-1.2.1_p20130110-r1.ebuild  | 97 +++++++++++++++++++++
 .../libRocket/libRocket-1.2.1_p20130110.ebuild     | 82 ++++++++++++++++++
 dev-libs/libRocket/libRocket-1.3.0.0.ebuild        | 99 ++++++++++++++++++++++
 dev-libs/libRocket/libRocket-9999.ebuild           | 98 +++++++++++++++++++++
 dev-libs/libRocket/metadata.xml                    | 11 +++
 8 files changed, 477 insertions(+)
 create mode 100644 dev-libs/libRocket/Manifest
 create mode 100644 dev-libs/libRocket/files/libRocket-1.2.1-build.patch
 create mode 100644 dev-libs/libRocket/files/libRocket-1.3.0.0-build.patch
 create mode 100644 dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
 create mode 100644 dev-libs/libRocket/libRocket-1.2.1_p20130110.ebuild
 create mode 100644 dev-libs/libRocket/libRocket-1.3.0.0.ebuild
 create mode 100644 dev-libs/libRocket/libRocket-9999.ebuild
 create mode 100644 dev-libs/libRocket/metadata.xml

(limited to 'dev-libs/libRocket')

diff --git a/dev-libs/libRocket/Manifest b/dev-libs/libRocket/Manifest
new file mode 100644
index 000000000000..a0c54f76284a
--- /dev/null
+++ b/dev-libs/libRocket/Manifest
@@ -0,0 +1,2 @@
+DIST libRocket-1.2.1_p20130110.tar.xz 845572 SHA256 5661f0d1b0a3e19b9f2856b9927ed7ec4ad6939e732230832cd701bf078a732b SHA512 1c474e0cad2e13ebe6102cd5d31c3fa61370d23062c31fd7703ec431f0da56f008c9711b49b73d8a9b32af0313e2cb3aa8c46888a36044fef05c15fe1cbc23b5 WHIRLPOOL 52ef88ebc35ac762c6b50fbaed8713b2568f80bc65390e696537f4935eaf1c4182a64b414fd6bfadb3e1a6cadb0589fcb20bc12c26e3ea87edaf342b5ff09bb6
+DIST libRocket-1.3.0.0.tar.gz 1858846 SHA256 574e992ac0bb62c1aa782114986d440ade69f4408971d0fb4ddc5922df761b75 SHA512 579fb5b9ca48b44999ca9c64e5fde3f28b83b12487928d34cf6e2834e60c4fff06c845832d38387f4ba639e2bd906b96940da4ce5e4c73625c48c6658726d3bd WHIRLPOOL a72c72c38780bc4dba9fbdb14365b675579e0a4d251c88bcf780fa076c16728c09c9ba7dff733d8f54da8064184e585ea568e12275f8e7ab86d55333a6242b0f
diff --git a/dev-libs/libRocket/files/libRocket-1.2.1-build.patch b/dev-libs/libRocket/files/libRocket-1.2.1-build.patch
new file mode 100644
index 000000000000..e578b441f42b
--- /dev/null
+++ b/dev-libs/libRocket/files/libRocket-1.2.1-build.patch
@@ -0,0 +1,44 @@
+From: Julian Ospald <hasufell@gentoo.org>
+--- Build/CMakeLists.txt
++++ Build/CMakeLists.txt
+@@ -11,6 +11,9 @@
+ 
+ project(libRocket C CXX)
+ 
++# paths
++include(GNUInstallDirs)
++
+ set(LIBROCKET_VERSION_MAJOR 1)
+ set(LIBROCKET_VERSION_MINOR 2)
+ set(LIBROCKET_VERSION_PATCH 1)
+@@ -131,8 +134,8 @@
+     endif()
+ 
+     install(TARGETS ${NAME}
+-            LIBRARY DESTINATION lib
+-            ARCHIVE DESTINATION lib
++            LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++            ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+     )
+ endforeach(library)
+ 
+@@ -237,7 +240,7 @@
+         endif()
+     endif()
+    
+-    set(SAMPLES_DIR opt/Rocket/Samples)
++    set(SAMPLES_DIR opt/Rocket/Samples CACHE PATH "path to samples dir")
+ 
+     # The samples use the shell library
+     include_directories(${PROJECT_SOURCE_DIR}/Samples/shell/include)
+@@ -256,8 +259,8 @@
+     target_link_libraries(${sample_LIBRARIES})
+ 
+     install(TARGETS shell
+-            LIBRARY DESTINATION lib
+-            ARCHIVE DESTINATION lib
++            LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++            ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+     )
+ 
+     list(APPEND samples treeview customlog drag loaddocument)
diff --git a/dev-libs/libRocket/files/libRocket-1.3.0.0-build.patch b/dev-libs/libRocket/files/libRocket-1.3.0.0-build.patch
new file mode 100644
index 000000000000..e578b441f42b
--- /dev/null
+++ b/dev-libs/libRocket/files/libRocket-1.3.0.0-build.patch
@@ -0,0 +1,44 @@
+From: Julian Ospald <hasufell@gentoo.org>
+--- Build/CMakeLists.txt
++++ Build/CMakeLists.txt
+@@ -11,6 +11,9 @@
+ 
+ project(libRocket C CXX)
+ 
++# paths
++include(GNUInstallDirs)
++
+ set(LIBROCKET_VERSION_MAJOR 1)
+ set(LIBROCKET_VERSION_MINOR 2)
+ set(LIBROCKET_VERSION_PATCH 1)
+@@ -131,8 +134,8 @@
+     endif()
+ 
+     install(TARGETS ${NAME}
+-            LIBRARY DESTINATION lib
+-            ARCHIVE DESTINATION lib
++            LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++            ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+     )
+ endforeach(library)
+ 
+@@ -237,7 +240,7 @@
+         endif()
+     endif()
+    
+-    set(SAMPLES_DIR opt/Rocket/Samples)
++    set(SAMPLES_DIR opt/Rocket/Samples CACHE PATH "path to samples dir")
+ 
+     # The samples use the shell library
+     include_directories(${PROJECT_SOURCE_DIR}/Samples/shell/include)
+@@ -256,8 +259,8 @@
+     target_link_libraries(${sample_LIBRARIES})
+ 
+     install(TARGETS shell
+-            LIBRARY DESTINATION lib
+-            ARCHIVE DESTINATION lib
++            LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++            ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+     )
+ 
+     list(APPEND samples treeview customlog drag loaddocument)
diff --git a/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild b/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
new file mode 100644
index 000000000000..e5b4ef3c6f12
--- /dev/null
+++ b/dev-libs/libRocket/libRocket-1.2.1_p20130110-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils eutils python-r1 multilib-minimal
+
+DESCRIPTION="A HTML/CSS User Interface library"
+HOMEPAGE="http://librocket.com/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="python samples"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+	>=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
+	python? (
+		${PYTHON_DEPS}
+		dev-libs/boost[${PYTHON_USEDEP}]
+	)
+	samples? (
+		virtual/opengl
+		x11-libs/libXext
+		x11-libs/libX11
+	)"
+DEPEND="${RDEPEND}"
+
+DOCS=( changelog.txt readme.md )
+
+python_BUILD_DIR=${WORKDIR}/${P}_build_python
+CMAKE_USE_DIR="${S}"/Build
+
+multilib_src_configure() {
+	local mycmakeargs=(
+		-DBUILD_PYTHON_BINDINGS=OFF
+		-DSAMPLES_DIR=/usr/share/${PN}/samples
+	)
+
+	if multilib_is_native_abi ; then
+		mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
+	else
+		mycmakeargs+=( -DBUILD_SAMPLES=OFF )
+	fi
+
+	cmake-utils_src_configure
+
+	if multilib_is_native_abi ; then
+		if use python ; then
+			cfgpybind() {
+				local mycmakeargs=(
+					-DBUILD_PYTHON_BINDINGS=ON
+					-DCMAKE_SKIP_RPATH=YES
+				)
+				BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
+			}
+			einfo "configuring python binding"
+			python_foreach_impl cfgpybind
+		fi
+	fi
+}
+
+multilib_src_compile() {
+	cmake-utils_src_compile
+	local abi_build_dir=${BUILD_DIR}
+
+	if multilib_is_native_abi ; then
+		if use python ; then
+			buildpybind() {
+				cp "${abi_build_dir}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
+				BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
+			}
+			einfo "compiling python binding"
+			python_foreach_impl buildpybind
+		fi
+	fi
+}
+
+multilib_src_install() {
+	cmake-utils_src_install
+
+	if multilib_is_native_abi ; then
+		if use python ; then
+			instpybind() {
+				python_domodule "${S}"/bin/rocket.py
+				exeinto "$(python_get_sitedir)"
+				doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
+			}
+			einfo "installing python binding"
+			python_foreach_impl instpybind
+		fi
+	fi
+}
diff --git a/dev-libs/libRocket/libRocket-1.2.1_p20130110.ebuild b/dev-libs/libRocket/libRocket-1.2.1_p20130110.ebuild
new file mode 100644
index 000000000000..6f75e7f0285d
--- /dev/null
+++ b/dev-libs/libRocket/libRocket-1.2.1_p20130110.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils eutils python-r1
+
+DESCRIPTION="A HTML/CSS User Interface library"
+HOMEPAGE="http://librocket.com/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="python samples"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="media-libs/freetype
+	python? (
+		${PYTHON_DEPS}
+		dev-libs/boost[python]
+	)
+	samples? (
+		virtual/opengl
+		x11-libs/libXext
+		x11-libs/libX11
+	)"
+DEPEND="${RDEPEND}"
+
+python_BUILD_DIR=${WORKDIR}/${P}_build_python
+CMAKE_USE_DIR="${S}"/Build
+
+src_configure() {
+	local mycmakeargs=(
+		-DBUILD_PYTHON_BINDINGS=OFF
+		$(cmake-utils_use_build samples SAMPLES)
+		-DSAMPLES_DIR=/usr/share/${PN}/samples
+	)
+
+	cmake-utils_src_configure
+
+	if use python ; then
+		cfgpybind() {
+			local mycmakeargs=(
+				-DBUILD_PYTHON_BINDINGS=ON
+				-DCMAKE_SKIP_RPATH=YES
+			)
+			BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
+		}
+		einfo "configuring python binding"
+		python_foreach_impl cfgpybind
+	fi
+}
+
+src_compile() {
+	cmake-utils_src_compile
+
+	if use python ; then
+		buildpybind() {
+			cp "${WORKDIR}"/${P}_build/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
+			BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
+		}
+		einfo "compiling python binding"
+		python_foreach_impl buildpybind
+	fi
+}
+
+src_install() {
+	cmake-utils_src_install
+
+	if use python ; then
+		instpybind() {
+			python_domodule bin/rocket.py
+			exeinto "$(python_get_sitedir)"
+			doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
+		}
+		einfo "installing python binding"
+		python_foreach_impl instpybind
+	fi
+}
diff --git a/dev-libs/libRocket/libRocket-1.3.0.0.ebuild b/dev-libs/libRocket/libRocket-1.3.0.0.ebuild
new file mode 100644
index 000000000000..135043c652b5
--- /dev/null
+++ b/dev-libs/libRocket/libRocket-1.3.0.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils eutils python-r1 multilib-minimal
+
+DESCRIPTION="A HTML/CSS User Interface library"
+HOMEPAGE="http://librocket.com/"
+SRC_URI="https://github.com/libRocket/libRocket/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86"
+IUSE="python samples"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+	>=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
+	python? (
+		${PYTHON_DEPS}
+		dev-libs/boost[${PYTHON_USEDEP}]
+	)
+	samples? (
+		virtual/opengl
+		x11-libs/libXext
+		x11-libs/libX11
+	)"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-release-${PV}
+
+DOCS=( changelog.txt readme.md )
+
+python_BUILD_DIR=${WORKDIR}/${P}_build_python
+CMAKE_USE_DIR="${S}"/Build
+
+multilib_src_configure() {
+	local mycmakeargs=(
+		-DBUILD_PYTHON_BINDINGS=OFF
+		-DSAMPLES_DIR=/usr/share/${PN}/samples
+	)
+
+	if multilib_is_native_abi ; then
+		mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
+	else
+		mycmakeargs+=( -DBUILD_SAMPLES=OFF )
+	fi
+
+	cmake-utils_src_configure
+
+	if multilib_is_native_abi ; then
+		if use python ; then
+			cfgpybind() {
+				local mycmakeargs=(
+					-DBUILD_PYTHON_BINDINGS=ON
+					-DCMAKE_SKIP_RPATH=YES
+				)
+				BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
+			}
+			einfo "configuring python binding"
+			python_foreach_impl cfgpybind
+		fi
+	fi
+}
+
+multilib_src_compile() {
+	cmake-utils_src_compile
+	local abi_build_dir=${BUILD_DIR}
+
+	if multilib_is_native_abi ; then
+		if use python ; then
+			buildpybind() {
+				cp "${abi_build_dir}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
+				BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
+			}
+			einfo "compiling python binding"
+			python_foreach_impl buildpybind
+		fi
+	fi
+}
+
+multilib_src_install() {
+	cmake-utils_src_install
+
+	if multilib_is_native_abi ; then
+		if use python ; then
+			instpybind() {
+				python_domodule "${S}"/bin/rocket.py
+				exeinto "$(python_get_sitedir)"
+				doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
+			}
+			einfo "installing python binding"
+			python_foreach_impl instpybind
+		fi
+	fi
+}
diff --git a/dev-libs/libRocket/libRocket-9999.ebuild b/dev-libs/libRocket/libRocket-9999.ebuild
new file mode 100644
index 000000000000..8f98fc148ffc
--- /dev/null
+++ b/dev-libs/libRocket/libRocket-9999.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils git-2 python-r1 multilib-minimal
+
+DESCRIPTION="A HTML/CSS User Interface library"
+HOMEPAGE="http://librocket.com/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/hasufell/libRocket.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="python samples"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+	>=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
+	python? (
+		${PYTHON_DEPS}
+		dev-libs/boost[${PYTHON_USEDEP}]
+	)
+	samples? (
+		virtual/opengl
+		x11-libs/libXext
+		x11-libs/libX11
+	)"
+DEPEND="${RDEPEND}"
+
+DOCS=( changelog.txt readme.md )
+
+python_BUILD_DIR=${WORKDIR}/${P}_build_python
+CMAKE_USE_DIR="${S}"/Build
+
+multilib_src_configure() {
+	local mycmakeargs=(
+		-DBUILD_PYTHON_BINDINGS=OFF
+		-DSAMPLES_DIR=/usr/share/${PN}/samples
+	)
+
+	if multilib_is_native_abi ; then
+		mycmakeargs+=( $(cmake-utils_use_build samples SAMPLES) )
+	else
+		mycmakeargs+=( -DBUILD_SAMPLES=OFF )
+	fi
+
+	cmake-utils_src_configure
+
+	if multilib_is_native_abi ; then
+		if use python ; then
+			cfgpybind() {
+				local mycmakeargs=(
+					-DBUILD_PYTHON_BINDINGS=ON
+					-DCMAKE_SKIP_RPATH=YES
+				)
+				BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_configure
+			}
+			einfo "configuring python binding"
+			python_foreach_impl cfgpybind
+		fi
+	fi
+}
+
+multilib_src_compile() {
+	cmake-utils_src_compile
+	local abi_build_dir=${BUILD_DIR}
+
+	if multilib_is_native_abi ; then
+		if use python ; then
+			buildpybind() {
+				cp "${abi_build_dir}"/{libRocketCore*,libRocketControls*} "${python_BUILD_DIR}-${EPYTHON}"/ || die
+				BUILD_DIR="${python_BUILD_DIR}-${EPYTHON}" cmake-utils_src_make _rocketcontrols/fast _rocketcore/fast
+			}
+			einfo "compiling python binding"
+			python_foreach_impl buildpybind
+		fi
+	fi
+}
+
+multilib_src_install() {
+	cmake-utils_src_install
+
+	if multilib_is_native_abi ; then
+		if use python ; then
+			instpybind() {
+				python_domodule "${S}"/bin/rocket.py
+				exeinto "$(python_get_sitedir)"
+				doexe ${python_BUILD_DIR}-${EPYTHON}/_rocket{core,controls}.so
+			}
+			einfo "installing python binding"
+			python_foreach_impl instpybind
+		fi
+	fi
+}
diff --git a/dev-libs/libRocket/metadata.xml b/dev-libs/libRocket/metadata.xml
new file mode 100644
index 000000000000..1649dd24542c
--- /dev/null
+++ b/dev-libs/libRocket/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+	<maintainer>
+		<email>maintainer-needed@gentoo.org</email>
+	</maintainer>
+	<use>
+		<flag name='samples'>Build samples</flag>
+	</use>
+</pkgmetadata>
+
-- 
cgit v1.2.3-65-gdbad