From 0d5b5a0955b1fc354ef8d42dc7809400170c37a8 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Sat, 26 Oct 2019 16:33:39 +0200
Subject: dev-python/nose2: Drop obsolete RDEPEND

Thanks-to: Chris Mayo <aklhfex@gmail.com>
Closes: https://bugs.gentoo.org/681818
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
---
 dev-python/nose2/nose2-0.9.1-r1.ebuild | 40 ++++++++++++++++++++++++++++++++
 dev-python/nose2/nose2-0.9.1.ebuild    | 42 ----------------------------------
 2 files changed, 40 insertions(+), 42 deletions(-)
 create mode 100644 dev-python/nose2/nose2-0.9.1-r1.ebuild
 delete mode 100644 dev-python/nose2/nose2-0.9.1.ebuild

(limited to 'dev-python/nose2')

diff --git a/dev-python/nose2/nose2-0.9.1-r1.ebuild b/dev-python/nose2/nose2-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..22dd4594b981
--- /dev/null
+++ b/dev-python/nose2/nose2-0.9.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Next generation unittest with plugins"
+HOMEPAGE="https://github.com/nose-devs/nose2"
+SRC_URI="https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+BDEPEND="
+	dev-python/setuptools[${PYTHON_USEDEP}]
+	doc? ( >=dev-python/sphinx-1.0.5[${PYTHON_USEDEP}] )
+"
+DEPEND="
+	>=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+	>=dev-python/six-1.1[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+python_compile_all() {
+	use doc && emake -C docs html
+}
+
+python_test() {
+	"${PYTHON}" -m nose2.__main__ || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+	use doc && local HTML_DOCS=( docs/_build/html/. )
+
+	distutils-r1_python_install_all
+}
diff --git a/dev-python/nose2/nose2-0.9.1.ebuild b/dev-python/nose2/nose2-0.9.1.ebuild
deleted file mode 100644
index 32043d32695c..000000000000
--- a/dev-python/nose2/nose2-0.9.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{5,6,7} )
-inherit distutils-r1
-
-DESCRIPTION="Next generation unittest with plugins"
-HOMEPAGE="https://github.com/nose-devs/nose2"
-SRC_URI="https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-BDEPEND="
-	dev-python/setuptools[${PYTHON_USEDEP}]
-	doc? ( >=dev-python/sphinx-1.0.5[${PYTHON_USEDEP}] )
-"
-DEPEND="
-	>=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
-	>=dev-python/six-1.1[${PYTHON_USEDEP}]
-"
-RDEPEND="${DEPEND}
-	>=dev-python/cov-core-1.12[${PYTHON_USEDEP}]
-"
-
-python_compile_all() {
-	use doc && emake -C docs html
-}
-
-python_test() {
-	"${PYTHON}" -m nose2.__main__ || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-	use doc && local HTML_DOCS=( docs/_build/html/. )
-
-	distutils-r1_python_install_all
-}
-- 
cgit v1.2.3-65-gdbad