From 56bd759df1d0c750a065b8c845e93d5dfa6b549d Mon Sep 17 00:00:00 2001
From: "Robin H. Johnson" <robbat2@gentoo.org>
Date: Sat, 8 Aug 2015 13:49:04 -0700
Subject: proj/gentoo: Initial commit
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts
X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
---
 games-util/gamepick/Manifest             |  1 +
 games-util/gamepick/gamepick-0.35.ebuild | 41 ++++++++++++++++++++++++++++++++
 games-util/gamepick/metadata.xml         |  5 ++++
 3 files changed, 47 insertions(+)
 create mode 100644 games-util/gamepick/Manifest
 create mode 100644 games-util/gamepick/gamepick-0.35.ebuild
 create mode 100644 games-util/gamepick/metadata.xml

(limited to 'games-util/gamepick')

diff --git a/games-util/gamepick/Manifest b/games-util/gamepick/Manifest
new file mode 100644
index 000000000000..1ae8a41a741c
--- /dev/null
+++ b/games-util/gamepick/Manifest
@@ -0,0 +1 @@
+DIST gamepick-0.35.tar.gz 156725 SHA256 82e7e6126bd7917ebf65a561c8170075ae0c34502ef018b1663ad49b5e562039 SHA512 bd77d6584cb9bb5c358179226d20a1995badd7603332bde6692ecca6c30f26fe06e6ea202e04bd40c006e9f43ae8fcd885a09bcb696227be3da823dd68d5053c WHIRLPOOL 485fcba1421fa92039ea35314f28705372af5ed44c0c1caf5c992e71462dd658685b4e371c561c00ea9251ff82c6f5fd1f23415250a96c4432150f9b556fb4db
diff --git a/games-util/gamepick/gamepick-0.35.ebuild b/games-util/gamepick/gamepick-0.35.ebuild
new file mode 100644
index 000000000000..537df160f2ab
--- /dev/null
+++ b/games-util/gamepick/gamepick-0.35.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Launch opengl games with custom graphic settings"
+HOMEPAGE="http://www.rillion.net/gamepick/index.html"
+SRC_URI="http://www.rillion.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+	virtual/pkgconfig"
+
+src_prepare() {
+	sed -i \
+		-e "s:/etc:${GAMES_SYSCONFDIR}:" \
+		src/gamepick.h || die
+
+	sed -i \
+		-e 's/-O2//' \
+		src/Makefile.in || die
+}
+
+src_install() {
+	default
+
+	dodir "${GAMES_SYSCONFDIR}"
+	touch "${D}/${GAMES_SYSCONFDIR}"/${PN}.conf
+
+	newicon gamepick-48x48.xpm ${PN}.xpm
+	make_desktop_entry ${PN} ${PN}
+
+	prepgamesdirs
+}
diff --git a/games-util/gamepick/metadata.xml b/games-util/gamepick/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/gamepick/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
-- 
cgit v1.2.3-65-gdbad