From b88ba1f34c0ec2f851e4562687181b633c70c9ce Mon Sep 17 00:00:00 2001
From: James Le Cuirot <chewi@gentoo.org>
Date: Sun, 7 Mar 2021 22:48:50 +0000
Subject: net-print/hplip-plugin: Version bump to 3.21.2

Closes: https://bugs.gentoo.org/774435
Package-Manager: Portage-3.0.16, Repoman-3.0.2
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
---
 net-print/hplip-plugin/Manifest                   |  1 +
 net-print/hplip-plugin/hplip-plugin-3.21.2.ebuild | 72 +++++++++++++++++++++++
 2 files changed, 73 insertions(+)
 create mode 100644 net-print/hplip-plugin/hplip-plugin-3.21.2.ebuild

(limited to 'net-print/hplip-plugin')

diff --git a/net-print/hplip-plugin/Manifest b/net-print/hplip-plugin/Manifest
index 409f6e002ca0..d96201b14f9e 100644
--- a/net-print/hplip-plugin/Manifest
+++ b/net-print/hplip-plugin/Manifest
@@ -1,2 +1,3 @@
 DIST hplip-3.20.11-plugin.run 11514293 BLAKE2B b3b7698a45e5e68a25ec1216e736484d26546b657f4a519a153acf0280847667e7ca81afc988f722668746281857d51d9e1703857514ffe5b57dea85f2bae4d3 SHA512 9075c1ac8e8f6e12d33b81b633025259f54352ea00271eec07ee898fd9a164445519608fc9ea61a7157845a4a03f87c28f486c7994f0d7db81d11d3fe51f1876
 DIST hplip-3.20.9-plugin.run 11515336 BLAKE2B 27686828374675412ae82a0a5be121c87dbd9ed3adb8d5f30e2f946e315140a5641fdbc60d7f952323060de7fb7bce77b21f19e0d07aa0c5c36e898732030b8b SHA512 bbb5c5768c0f1e88f960f9decff65d70942bc40d8f0443fa2e1c0507895e2e6ba7bc8e0fbec5a74b335787ac45bd3c34cf6bc4d5e544ce7c2ef0965e074a440a
+DIST hplip-3.21.2-plugin.run 11514233 BLAKE2B 262f23c34632f7ba4a9c6e1c4533d0fd44b025e476c0f28f0fc68bc401430c503233583ae381d6c74a89a996b750603910000c6fdc6b0b606e32d56c82ed07f4 SHA512 62f3b6e369bdd1b2145f814901314c78ae5d7426734c92b0511f8ea4a925e24880875a1cfd1623ef800dcfdf3cf5b1c5d83032a19ca200547a4555b0d944f8e6
diff --git a/net-print/hplip-plugin/hplip-plugin-3.21.2.ebuild b/net-print/hplip-plugin/hplip-plugin-3.21.2.ebuild
new file mode 100644
index 000000000000..cca0faecc4c1
--- /dev/null
+++ b/net-print/hplip-plugin/hplip-plugin-3.21.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+DESCRIPTION="Proprietary plugins and firmware for HPLIP"
+HOMEPAGE="https://developers.hp.com/hp-linux-imaging-and-printing/plugins"
+SRC_URI="https://developers.hp.com/sites/default/files/hplip-${PV}-plugin.run"
+LICENSE="hplip-plugin"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="orblite"
+
+RDEPEND="
+	~net-print/hplip-${PV}
+	virtual/udev
+	orblite? (
+		media-gfx/sane-backends
+		>=sys-libs/glibc-2.26
+		virtual/libusb:0
+	)
+"
+DEPEND=""
+
+S=${WORKDIR}
+
+HPLIP_HOME=/usr/share/hplip
+
+# Binary prebuilt package
+QA_PREBUILT="${HPLIP_HOME}/*.so"
+
+# License does not allow us to redistribute the "source" package
+RESTRICT="mirror"
+
+src_install() {
+	local hplip_arch
+	case "${ARCH}" in
+		amd64) hplip_arch="x86_64" ;;
+		arm)   hplip_arch="arm32"  ;;
+		x86)   hplip_arch="x86_32" ;;
+		*)     die "Unsupported architecture." ;;
+	esac
+
+	insinto "${HPLIP_HOME}"/data/firmware
+	doins *.fw.gz
+
+	for plugin in *-${hplip_arch}.so; do
+		local plugin_type=prnt
+		case "${plugin}" in
+			bb_orblite-*)
+				use orblite || continue
+				plugin_type=scan ;;
+			bb_*)
+				plugin_type=scan ;;
+			fax_*)
+				plugin_type=fax ;;
+		esac
+
+		exeinto "${HPLIP_HOME}"/${plugin_type}/plugins
+		newexe ${plugin} ${plugin/-${hplip_arch}}
+	done
+
+	insinto /var/lib/hp
+	newins - hplip.state <<-_EOF_
+		[plugin]
+		installed = 1
+		eula = 1
+		version = ${PV}
+	_EOF_
+}
-- 
cgit v1.2.3-65-gdbad