From fb58e8da0267a7e72ffdcf20b2ba48c92ea1b2d6 Mon Sep 17 00:00:00 2001
From: Matt Turner <mattst88@gentoo.org>
Date: Tue, 12 Nov 2019 22:51:25 -0800
Subject: sys-boot/aboot: Port to EAPI=7

Closes: https://bugs.gentoo.org/697182
Signed-off-by: Matt Turner <mattst88@gentoo.org>
---
 sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild | 22 ++++++++++++----------
 1 file changed, 12 insertions(+), 10 deletions(-)

(limited to 'sys-boot')

diff --git a/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild b/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
index d6c38443b2c4..cba6251a37af 100644
--- a/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
+++ b/sys-boot/aboot/aboot-1.0_pre20040408-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit eutils toolchain-funcs
 
@@ -30,18 +30,20 @@ src_unpack() {
 	cd "${S}"/include
 	ln -s asm-alpha asm || die
 	touch linux/config.h || die
-	cd "${S}"
-	epatch "${FILESDIR}/aboot-gcc-3.4.patch"
-	epatch "${FILESDIR}/aboot-pt_note.patch"
+}
+
+src_prepare() {
+	eapply "${FILESDIR}/aboot-gcc-3.4.patch"
+	eapply "${FILESDIR}/aboot-pt_note.patch"
 	# Bug 364697
-	epatch "${FILESDIR}/aboot-define_stat_only_in_userspace.patch"
-	epatch "${FILESDIR}"/aboot-respect-AR.patch
-	epatch "${FILESDIR}"/aboot-gnu90.patch
+	eapply "${FILESDIR}/aboot-define_stat_only_in_userspace.patch"
+	eapply "${FILESDIR}"/aboot-respect-AR.patch
+	eapply "${FILESDIR}"/aboot-gnu90.patch
 
 	# Modified patch from Debian to add netboot support
-	epatch "${WORKDIR}"/aboot_gentoo.diff
+	eapply "${WORKDIR}"/aboot_gentoo.diff
 
-	epatch_user
+	eapply_user
 }
 
 src_compile() {
-- 
cgit v1.2.3-65-gdbad