From c31676125999f57f4e98a7b2c63346f6fe14261f Mon Sep 17 00:00:00 2001
From: "Jorge Manuel B. S. Vicetto (jmbsvicetto)" <jmbsvicetto@gentoo.org>
Date: Thu, 24 Aug 2017 09:59:56 +0000
Subject: www-apps/dokuwiki: Add releases 20160626e and 20170219e - security
 bump to address CVE-2017-{12583,12979,12980}. Fixes bug 627154 and bug
 628482.

Package-Manager: Portage-2.3.6, Repoman-2.3.2
---
 www-apps/dokuwiki/Manifest                  |  4 +-
 www-apps/dokuwiki/dokuwiki-20160626b.ebuild | 77 -----------------------------
 www-apps/dokuwiki/dokuwiki-20160626e.ebuild | 77 +++++++++++++++++++++++++++++
 www-apps/dokuwiki/dokuwiki-20170219b.ebuild | 77 -----------------------------
 www-apps/dokuwiki/dokuwiki-20170219e.ebuild | 77 +++++++++++++++++++++++++++++
 5 files changed, 156 insertions(+), 156 deletions(-)
 delete mode 100644 www-apps/dokuwiki/dokuwiki-20160626b.ebuild
 create mode 100644 www-apps/dokuwiki/dokuwiki-20160626e.ebuild
 delete mode 100644 www-apps/dokuwiki/dokuwiki-20170219b.ebuild
 create mode 100644 www-apps/dokuwiki/dokuwiki-20170219e.ebuild

(limited to 'www-apps/dokuwiki')

diff --git a/www-apps/dokuwiki/Manifest b/www-apps/dokuwiki/Manifest
index e88109f71ada..5b03db3d2218 100644
--- a/www-apps/dokuwiki/Manifest
+++ b/www-apps/dokuwiki/Manifest
@@ -1,2 +1,2 @@
-DIST dokuwiki-2016-06-26b.tgz 3464109 SHA256 eda6421fbd381d67ac6c31c5649fba7e6526904fc186df18191641e5387d8b4f SHA512 6952e89cec7866897b93af5d2719d34e98927545c9ec73600378599d6a8fb8e11d44adf385b4911b9f666dac3f0c7e76b39e589ff28c93da8c83303390d4ff2b WHIRLPOOL 0d7f036b60676312e1adf689606eb10dfb30f5e509bcad9b333ddb32b5d0b1255f4d8c93e08d7b427393ae4b43ee57a697a310c879ec2b7c26522f46ae5165d8
-DIST dokuwiki-2017-02-19b.tgz 3505444 SHA256 88a4d6c83283a1059e9765477667262f15d443f50e48f583c7dc5d55c2abcdb6 SHA512 207f20fb4b5d72cae2cfd7446b43b549e58fb1a57fe5c6676979dc07ec22370841841eb9b455f2f88aa734425a7735f162708f205535498e331035e7bd1fcbb8 WHIRLPOOL d1d62e93d9f940039f3fd24f9ce6b621eaf7632d56223fa78f3650fc5e10ef8197f43f92e7e4bfd56b227cf0d6884a1f8e5ff5b4cf7a90fcdeca505d4f00c45e
+DIST dokuwiki-2016-06-26e.tgz 3464178 SHA256 af63ccaa54b617a809d78642c7e83fe6581c545b869aab7440d63ab82b0120bd SHA512 b47c3a31b0bc731392703ed8d705717e7d1b75db0c44d822d8791c1e409d5285fe863a3dbd13bc60b73c01ca268f7a73a6a24c90edd211fd5c124d3a8be70039 WHIRLPOOL 028c5ac4c72d0bc29d8d534133e61749683169f1f5a5ad4627fff8cf9bcd9bd5b4cb6e5ac845cd1572f9417fe2c23e2234d484c0920250ffacc830075abfa913
+DIST dokuwiki-2017-02-19e.tgz 3505643 SHA256 93172a28ab88107a8abac1e6a34fa6cef54b6e407cd03a8cc14d2a604a63e888 SHA512 6fadb64f9d8394731f346708849d8828b33f4f775e23bca97896b2e06bbfc3b70a6fc17d63dcef8199fdb0aaf0b8291eb0eebcdff7b81524b2d454229eb20be4 WHIRLPOOL b3eeee3bff1d1ea8bd62432dcd79480b929cdb4a86331aa0179690d6c7602ba8176d79c276316ea4a9b81a645e91e7739d2332dc23ccc249867328556f5540da
diff --git a/www-apps/dokuwiki/dokuwiki-20160626b.ebuild b/www-apps/dokuwiki/dokuwiki-20160626b.ebuild
deleted file mode 100644
index bc4d3d6cab96..000000000000
--- a/www-apps/dokuwiki/dokuwiki-20160626b.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit webapp
-
-# upstream uses dashes in the datestamp
-MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-MY_PV="${MY_BASE_PV}${PV:8:1}"
-
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
-HOMEPAGE="https://www.dokuwiki.org/DokuWiki"
-SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="gd"
-
-DEPEND=""
-RDEPEND="
-	>=dev-lang/php-5.3[xml]
-	virtual/httpd-php:*
-	gd? ( ||
-		(
-			dev-lang/php[gd]
-			media-gfx/imagemagick
-		)
-	)
-"
-
-need_httpd_cgi
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_prepare() {
-	# create initial changes file
-	touch data/changes.log
-}
-
-src_install() {
-	webapp_src_preinst
-
-	dodoc README
-	rm -f README COPYING
-
-	docinto scripts
-	dodoc bin/*
-	rm -rf bin
-
-	insinto "${MY_HTDOCSDIR}"
-	doins -r .
-
-	# Copy custom .htaccess that works with both apache 2.2 and 2.4
-	for dir in "conf" "data" "inc" "inc/lang"; do
-		insinto "${MY_HTDOCSDIR}/${dir}"
-		newins "${FILESDIR}/htaccess" ".htaccess"
-	done
-
-	# Use custom .htaccess.dist that works with both apache 2.2 and 2.4
-	insinto "${MY_HTDOCSDIR}/"
-	newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
-
-	for x in $(find data/ -not -name '.htaccess'); do
-		webapp_serverowned "${MY_HTDOCSDIR}"/${x}
-	done
-
-	webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
-	webapp_configfile "${MY_HTDOCSDIR}"/conf
-
-	for x in $(find conf/ -not -name 'msg'); do
-		webapp_configfile "${MY_HTDOCSDIR}"/${x}
-	done
-
-	webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-	webapp_src_install
-}
diff --git a/www-apps/dokuwiki/dokuwiki-20160626e.ebuild b/www-apps/dokuwiki/dokuwiki-20160626e.ebuild
new file mode 100644
index 000000000000..d6e837cfd1cc
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20160626e.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit webapp
+
+# upstream uses dashes in the datestamp
+MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PV="${MY_BASE_PV}${PV:8:1}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
+HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
+SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gd"
+
+DEPEND=""
+RDEPEND="
+	>=dev-lang/php-5.3[xml]
+	virtual/httpd-php:*
+	gd? ( ||
+		(
+			dev-lang/php[gd]
+			media-gfx/imagemagick
+		)
+	)
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+	# create initial changes file
+	touch data/changes.log
+}
+
+src_install() {
+	webapp_src_preinst
+
+	dodoc README
+	rm -f README COPYING
+
+	docinto scripts
+	dodoc bin/*
+	rm -rf bin
+
+	insinto "${MY_HTDOCSDIR}"
+	doins -r .
+
+	# Copy custom .htaccess that works with both apache 2.2 and 2.4
+	for dir in "conf" "data" "inc" "inc/lang"; do
+		insinto "${MY_HTDOCSDIR}/${dir}"
+		newins "${FILESDIR}/htaccess" ".htaccess"
+	done
+
+	# Use custom .htaccess.dist that works with both apache 2.2 and 2.4
+	insinto "${MY_HTDOCSDIR}/"
+	newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
+
+	for x in $(find data/ -not -name '.htaccess'); do
+		webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+	done
+
+	webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
+	webapp_configfile "${MY_HTDOCSDIR}"/conf
+
+	for x in $(find conf/ -not -name 'msg'); do
+		webapp_configfile "${MY_HTDOCSDIR}"/${x}
+	done
+
+	webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+	webapp_src_install
+}
diff --git a/www-apps/dokuwiki/dokuwiki-20170219b.ebuild b/www-apps/dokuwiki/dokuwiki-20170219b.ebuild
deleted file mode 100644
index bc4d3d6cab96..000000000000
--- a/www-apps/dokuwiki/dokuwiki-20170219b.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit webapp
-
-# upstream uses dashes in the datestamp
-MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
-MY_PV="${MY_BASE_PV}${PV:8:1}"
-
-DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
-HOMEPAGE="https://www.dokuwiki.org/DokuWiki"
-SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="gd"
-
-DEPEND=""
-RDEPEND="
-	>=dev-lang/php-5.3[xml]
-	virtual/httpd-php:*
-	gd? ( ||
-		(
-			dev-lang/php[gd]
-			media-gfx/imagemagick
-		)
-	)
-"
-
-need_httpd_cgi
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-src_prepare() {
-	# create initial changes file
-	touch data/changes.log
-}
-
-src_install() {
-	webapp_src_preinst
-
-	dodoc README
-	rm -f README COPYING
-
-	docinto scripts
-	dodoc bin/*
-	rm -rf bin
-
-	insinto "${MY_HTDOCSDIR}"
-	doins -r .
-
-	# Copy custom .htaccess that works with both apache 2.2 and 2.4
-	for dir in "conf" "data" "inc" "inc/lang"; do
-		insinto "${MY_HTDOCSDIR}/${dir}"
-		newins "${FILESDIR}/htaccess" ".htaccess"
-	done
-
-	# Use custom .htaccess.dist that works with both apache 2.2 and 2.4
-	insinto "${MY_HTDOCSDIR}/"
-	newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
-
-	for x in $(find data/ -not -name '.htaccess'); do
-		webapp_serverowned "${MY_HTDOCSDIR}"/${x}
-	done
-
-	webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
-	webapp_configfile "${MY_HTDOCSDIR}"/conf
-
-	for x in $(find conf/ -not -name 'msg'); do
-		webapp_configfile "${MY_HTDOCSDIR}"/${x}
-	done
-
-	webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-	webapp_src_install
-}
diff --git a/www-apps/dokuwiki/dokuwiki-20170219e.ebuild b/www-apps/dokuwiki/dokuwiki-20170219e.ebuild
new file mode 100644
index 000000000000..d6e837cfd1cc
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20170219e.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit webapp
+
+# upstream uses dashes in the datestamp
+MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PV="${MY_BASE_PV}${PV:8:1}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
+HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
+SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gd"
+
+DEPEND=""
+RDEPEND="
+	>=dev-lang/php-5.3[xml]
+	virtual/httpd-php:*
+	gd? ( ||
+		(
+			dev-lang/php[gd]
+			media-gfx/imagemagick
+		)
+	)
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+	# create initial changes file
+	touch data/changes.log
+}
+
+src_install() {
+	webapp_src_preinst
+
+	dodoc README
+	rm -f README COPYING
+
+	docinto scripts
+	dodoc bin/*
+	rm -rf bin
+
+	insinto "${MY_HTDOCSDIR}"
+	doins -r .
+
+	# Copy custom .htaccess that works with both apache 2.2 and 2.4
+	for dir in "conf" "data" "inc" "inc/lang"; do
+		insinto "${MY_HTDOCSDIR}/${dir}"
+		newins "${FILESDIR}/htaccess" ".htaccess"
+	done
+
+	# Use custom .htaccess.dist that works with both apache 2.2 and 2.4
+	insinto "${MY_HTDOCSDIR}/"
+	newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
+
+	for x in $(find data/ -not -name '.htaccess'); do
+		webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+	done
+
+	webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
+	webapp_configfile "${MY_HTDOCSDIR}"/conf
+
+	for x in $(find conf/ -not -name 'msg'); do
+		webapp_configfile "${MY_HTDOCSDIR}"/${x}
+	done
+
+	webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+	webapp_src_install
+}
-- 
cgit v1.2.3-65-gdbad