From e96543dff22927a309f4bc9018e88ffd1eafd825 Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Wed, 21 Apr 2021 12:11:28 +0200
Subject: x11-misc/qt5ct: Fix install paths
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 x11-misc/qt5ct/files/qt5ct-1.2-cmake.patch | 22 +++++++++++++
 x11-misc/qt5ct/qt5ct-1.2-r1.ebuild         | 53 ++++++++++++++++++++++++++++++
 x11-misc/qt5ct/qt5ct-1.2.ebuild            | 48 ---------------------------
 3 files changed, 75 insertions(+), 48 deletions(-)
 create mode 100644 x11-misc/qt5ct/files/qt5ct-1.2-cmake.patch
 create mode 100644 x11-misc/qt5ct/qt5ct-1.2-r1.ebuild
 delete mode 100644 x11-misc/qt5ct/qt5ct-1.2.ebuild

(limited to 'x11-misc')

diff --git a/x11-misc/qt5ct/files/qt5ct-1.2-cmake.patch b/x11-misc/qt5ct/files/qt5ct-1.2-cmake.patch
new file mode 100644
index 000000000000..67313d824fa8
--- /dev/null
+++ b/x11-misc/qt5ct/files/qt5ct-1.2-cmake.patch
@@ -0,0 +1,22 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -39,7 +39,7 @@
+ set(QT_QTPATHS_EXECUTABLE ${QT_QTPATHS_EXECUTABLE}/qtpaths)
+ 
+ if(EXISTS ${QT_QTPATHS_EXECUTABLE})
+-    message(STATUS "Found qtpaths executable: " ${QT_QTPATHS_EXECUTABLE})    
++    message(STATUS "Found qtpaths executable: " ${QT_QTPATHS_EXECUTABLE})
+ else()
+     message(FATAL_ERROR "Could NOT find qtpaths executable")
+ endif()
+@@ -54,8 +54,8 @@
+ add_subdirectory(src/qt5ct-qtplugin)
+ add_subdirectory(src/qt5ct-style)
+ 
+-install(DIRECTORY qss DESTINATION ${CMAKE_INSTALL_DATADIR})
+-install(DIRECTORY colors DESTINATION ${CMAKE_INSTALL_DATADIR})
++install(DIRECTORY qss DESTINATION ${CMAKE_INSTALL_DATADIR}/qt5ct)
++install(DIRECTORY colors DESTINATION ${CMAKE_INSTALL_DATADIR}/qt5ct)
+ 
+ if(UNIX)
+     add_custom_target(distclean @echo cleaning for source distribution)
diff --git a/x11-misc/qt5ct/qt5ct-1.2-r1.ebuild b/x11-misc/qt5ct/qt5ct-1.2-r1.ebuild
new file mode 100644
index 000000000000..419efe47f940
--- /dev/null
+++ b/x11-misc/qt5ct/qt5ct-1.2-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
+HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
+SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+dbus"
+
+RDEPEND="
+	dev-qt/qtconcurrent:5
+	dev-qt/qtcore:5
+	dev-qt/qtgui:5=
+	dev-qt/qtwidgets:5
+	dbus? (
+		dev-qt/qtdbus:5
+		dev-qt/qtgui:5[dbus]
+	)
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+	dev-qt/linguist-tools:5
+	dev-qt/qtpaths:5
+"
+
+PATCHES=(
+	"${FILESDIR}"/${P}-cmake.patch
+)
+
+src_install() {
+	cmake_src_install
+
+	newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
+}
+
+pkg_postinst() {
+	if [[ -z ${REPLACING_VERSIONS} ]]; then
+		ewarn "qt5ct configuration won't be applied to the currently running sessions."
+		ewarn "Please relogin."
+	fi
+	if ! has_version 'dev-qt/qtsvg:5'; then
+		elog
+		elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
+		elog
+	fi
+}
diff --git a/x11-misc/qt5ct/qt5ct-1.2.ebuild b/x11-misc/qt5ct/qt5ct-1.2.ebuild
deleted file mode 100644
index cadb81998d16..000000000000
--- a/x11-misc/qt5ct/qt5ct-1.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
-HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
-SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+dbus"
-
-RDEPEND="
-	dev-qt/qtconcurrent:5
-	dev-qt/qtcore:5
-	dev-qt/qtgui:5=
-	dev-qt/qtwidgets:5
-	dbus? (
-		dev-qt/qtdbus:5
-		dev-qt/qtgui:5[dbus]
-	)
-"
-DEPEND="${RDEPEND}
-	dev-qt/linguist-tools:5
-	dev-qt/qtpaths:5
-"
-
-src_install() {
-	cmake_src_install
-
-	newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
-}
-
-pkg_postinst() {
-	if [[ -z ${REPLACING_VERSIONS} ]]; then
-		ewarn "qt5ct configuration won't be applied to the currently running sessions."
-		ewarn "Please relogin."
-	fi
-	if ! has_version 'dev-qt/qtsvg:5'; then
-		elog
-		elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
-		elog
-	fi
-}
-- 
cgit v1.2.3-65-gdbad