From 4c4a66d7e715644cdded32043fcda930e31ba259 Mon Sep 17 00:00:00 2001
From: Matt Smith <matt@offtopica.uk>
Date: Sun, 21 Mar 2021 10:51:13 +0000
Subject: x11-terms/zutty: new package.

Zutty is a terminal emulator for the X Window System, functionally similar to
several other X terminal emulators such as xterm, rxvt and countless others. It
is also similar to other, much more modern, GPU-accelerated terminal emulators
such as Alacritty and Kitty. What really sets Zutty apart is its radically
simple, yet extremely efficient rendering implementation, coupled with a
sufficiently complete feature set to make it useful for a wide range of users.
Zutty offers high throughput with low latency, and strives to conform to
relevant (published or de-facto) standards.

Package-Manager: Portage-3.0.17, Repoman-3.0.2
Signed-off-by: Matt Smith <matt@offtopica.uk>
Closes: https://github.com/gentoo/gentoo/pull/20028
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
---
 x11-terms/zutty/Manifest         |  1 +
 x11-terms/zutty/metadata.xml     | 26 ++++++++++++++++++++++++++
 x11-terms/zutty/zutty-0.8.ebuild | 29 +++++++++++++++++++++++++++++
 3 files changed, 56 insertions(+)
 create mode 100644 x11-terms/zutty/Manifest
 create mode 100644 x11-terms/zutty/metadata.xml
 create mode 100644 x11-terms/zutty/zutty-0.8.ebuild

(limited to 'x11-terms/zutty')

diff --git a/x11-terms/zutty/Manifest b/x11-terms/zutty/Manifest
new file mode 100644
index 000000000000..8c132647bf20
--- /dev/null
+++ b/x11-terms/zutty/Manifest
@@ -0,0 +1 @@
+DIST zutty-0.8.tar.gz 307235 BLAKE2B 897fea3735785ba1e8c811adbc90b96598c04f3ec19d9d3027745e5b9d3c1d21c55343b9409e48327139545e2675346be90d84af422d3ce97b1737cc287bb96b SHA512 75c5637fe8f0c8aff41e394a05f304f56bf03faf1dfa78807ca930a722536a93f54012f051f411b4e8ff478dd991f5b8ca1285fcd674879eac568c8971004317
diff --git a/x11-terms/zutty/metadata.xml b/x11-terms/zutty/metadata.xml
new file mode 100644
index 000000000000..3663ab431828
--- /dev/null
+++ b/x11-terms/zutty/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person" proxied="yes">
+    <email>matt@offtopica.uk</email>
+    <name>Matt Smith</name>
+  </maintainer>
+  <maintainer type="project" proxied="proxy">
+    <email>proxy-maint@gentoo.org</email>
+    <name>Proxy Maintainers</name>
+  </maintainer>
+  <longdescription lang="en">
+    Zutty is a terminal emulator for the X Window System, functionally
+    similar to several other X terminal emulators such as xterm, rxvt
+    and countless others. It is also similar to other, much more
+    modern, GPU-accelerated terminal emulators such as Alacritty and
+    Kitty. What really sets Zutty apart is its radically simple, yet
+    extremely efficient rendering implementation, coupled with a
+    sufficiently complete feature set to make it useful for a wide
+    range of users. Zutty offers high throughput with low latency, and
+    strives to conform to relevant (published or de-facto) standards.
+  </longdescription>
+  <upstream>
+    <remote-id type="github">tomszilagyi/zutty</remote-id>
+  </upstream>
+</pkgmetadata>
diff --git a/x11-terms/zutty/zutty-0.8.ebuild b/x11-terms/zutty/zutty-0.8.ebuild
new file mode 100644
index 000000000000..d4ab66148fff
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://github.com/tomszilagyi/zutty"
+SRC_URI="https://github.com/tomszilagyi/zutty/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="
+	media-libs/freetype:2
+	media-libs/libglvnd[X]
+	x11-libs/libXmu"
+DEPEND="
+	${COMMON_DEPEND}
+	${PYTHON_DEPS}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( doc/KEYS.org doc/USAGE.org )
-- 
cgit v1.2.3-65-gdbad