summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-block/compcache-tools/compcache-tools-0.6.2.ebuild33
-rw-r--r--sys-block/compcache-tools/files/compcache-tools-0.6_gentoo.patch10
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-block/compcache-tools/compcache-tools-0.6.2.ebuild b/sys-block/compcache-tools/compcache-tools-0.6.2.ebuild
new file mode 100644
index 0000000..01550ab
--- /dev/null
+++ b/sys-block/compcache-tools/compcache-tools-0.6.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+MY_P="${P/-tools/}"
+DESCRIPTION="Compressed in-memory swap device for Linux"
+HOMEPAGE="http://code.google.com/p/compcache/"
+SRC_URI="http://compcache.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}/sub-projects/rzscontrol"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.6_gentoo.patch"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin rzscontrol || die
+ doman man/rzscontrol.1 || die
+}
diff --git a/sys-block/compcache-tools/files/compcache-tools-0.6_gentoo.patch b/sys-block/compcache-tools/files/compcache-tools-0.6_gentoo.patch
new file mode 100644
index 0000000..9c454b1
--- /dev/null
+++ b/sys-block/compcache-tools/files/compcache-tools-0.6_gentoo.patch
@@ -0,0 +1,10 @@
+diff -ur a/sub-projects/rzscontrol/Makefile b/sub-projects/rzscontrol/Makefile
+--- a/sub-projects/rzscontrol/Makefile 2009-08-18 20:10:04.000000000 -0400
++++ b/sub-projects/rzscontrol/Makefile 2010-01-01 07:17:16.659296141 -0500
+@@ -1,5 +1,5 @@
+ all:
+- @gcc -g -Wall -D_GNU_SOURCE rzscontrol.c -o rzscontrol -I ../include -I../..
++ $(CC) $(CFLAGS) -Wall -D_GNU_SOURCE rzscontrol.c -o rzscontrol -I ../include -I../.. $(LDFLAGS)
+
+ doc:
+ @xmllint --noout --valid man/rzscontrol.xml