summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-03-19 22:27:05 +0100
committerMartin Väth <martin@mvath.de>2015-10-11 10:47:26 +0200
commit01451f3cbe50cd6f38b3d3a8fe3e1cb5a648af8f (patch)
tree51faca7560d66b840a9f4a6d040e89d48315dcab /sys-apps
parentBump noscript (diff)
downloadmv-01451f3cbe50cd6f38b3d3a8fe3e1cb5a648af8f.tar.gz
mv-01451f3cbe50cd6f38b3d3a8fe3e1cb5a648af8f.tar.bz2
mv-01451f3cbe50cd6f38b3d3a8fe3e1cb5a648af8f.zip
Bump getdelta. Use vcs-snapshot.eclass. Homepage without variable
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/cpi/ChangeLog7
-rw-r--r--sys-apps/cpi/cpi-1.3.ebuild9
-rw-r--r--sys-apps/starter/ChangeLog7
-rw-r--r--sys-apps/starter/starter-2.3.ebuild9
4 files changed, 14 insertions, 18 deletions
diff --git a/sys-apps/cpi/ChangeLog b/sys-apps/cpi/ChangeLog
index b8c3aeb7..f503a531 100644
--- a/sys-apps/cpi/ChangeLog
+++ b/sys-apps/cpi/ChangeLog
@@ -4,7 +4,10 @@
*cpi-1.3 (28 Feb 2012)
- 28 Feb 2011; Martin Väth <martin@mvath.de>
+ 19 Mar 2012; Martin Väth <martin@mvath.de>
+ Use vcs-snapshot.eclass
+
+ 28 Feb 2012; Martin Väth <martin@mvath.de>
Version bump, remove old ebuild.
*cpi-1.2 (05 Feb 2012)
@@ -15,5 +18,5 @@
*cpi-1.0 (03 Feb 2012)
- 03 Feb 2011; Martin Väth <martin@mvath.de>
+ 03 Feb 2012; Martin Väth <martin@mvath.de>
New ebuild from scratch.
diff --git a/sys-apps/cpi/cpi-1.3.ebuild b/sys-apps/cpi/cpi-1.3.ebuild
index d815fe19..daaaa1dd 100644
--- a/sys-apps/cpi/cpi-1.3.ebuild
+++ b/sys-apps/cpi/cpi-1.3.ebuild
@@ -4,9 +4,10 @@
EAPI="4"
RESTRICT="mirror"
+inherit vcs-snapshot
DESCRIPTION="A wrapper for cp -i -a, making use of diff"
-HOMEPAGE="https://github.com/vaeth/${PN}"
+HOMEPAGE="https://github.com/vaeth/cpi/"
SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
LICENSE="BSD"
@@ -14,12 +15,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="zsh-completion"
-src_unpack() {
- default
- cd *"${PN}"-*
- S="${PWD}"
-}
-
src_install() {
dobin "${PN}"
if use zsh-completion
diff --git a/sys-apps/starter/ChangeLog b/sys-apps/starter/ChangeLog
index 71e9aea9..8f7a4165 100644
--- a/sys-apps/starter/ChangeLog
+++ b/sys-apps/starter/ChangeLog
@@ -4,7 +4,10 @@
*starter-2.3 (28 Feb 2012)
- 28 Feb 2011; Martin Väth <martin@mvath.de>
+ 19 Mar 2012; Martin Väth <martin@mvath.de>
+ Use vcs-snapshot.eclass
+
+ 28 Feb 2012; Martin Väth <martin@mvath.de>
Version bump, remove old ebuild.
*starter-2.2 (31 Jan 2012)
@@ -14,5 +17,5 @@
*starter-2.0 (30 Jan 2012)
- 30 Jan 2011; Martin Väth <martin@mvath.de>
+ 30 Jan 2012; Martin Väth <martin@mvath.de>
New ebuild from scratch.
diff --git a/sys-apps/starter/starter-2.3.ebuild b/sys-apps/starter/starter-2.3.ebuild
index 4f2ec1a5..ba2293fb 100644
--- a/sys-apps/starter/starter-2.3.ebuild
+++ b/sys-apps/starter/starter-2.3.ebuild
@@ -4,9 +4,10 @@
EAPI="4"
RESTRICT="mirror"
+inherit vcs-snapshot
DESCRIPTION="POSIX shell script and function to schedule commands"
-HOMEPAGE="https://github.com/vaeth/${PN}"
+HOMEPAGE="https://github.com/vaeth/starter/"
SRC_URI="http://github.com/vaeth/${PN}/tarball/release-${PV} -> ${P}.tar.gz"
LICENSE="BSD"
@@ -14,12 +15,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="zsh-completion"
-src_unpack() {
- default
- cd *"${PN}"-*
- S="${PWD}"
-}
-
src_install() {
local i
insinto /usr/bin