summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2009-02-02 23:25:14 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2009-02-02 23:25:14 +0000
commitf95a01471454270512652e6ffbd31729514c6e0c (patch)
tree3224d867ecb355139ec34db7b8c9b5bec5833120 /src/patchsets/resin
parentupdated spanish translation (jose maria alonso) (diff)
downloadgentoo-f95a01471454270512652e6ffbd31729514c6e0c.tar.gz
gentoo-f95a01471454270512652e6ffbd31729514c6e0c.tar.bz2
gentoo-f95a01471454270512652e6ffbd31729514c6e0c.zip
Add patches for Resin 3.2.1
Diffstat (limited to 'src/patchsets/resin')
-rw-r--r--src/patchsets/resin/3.2.1/mod_caucho-3.2.1-gentoo.patch17
-rw-r--r--src/patchsets/resin/3.2.1/mod_caucho-3.2.1-java.patch144
-rw-r--r--src/patchsets/resin/3.2.1/mod_caucho-3.2.1-ssl.patch20
-rw-r--r--src/patchsets/resin/3.2.1/resin-3.2.1-Makefile.am.patch40
-rw-r--r--src/patchsets/resin/3.2.1/resin-3.2.1-build.xml.patch196
5 files changed, 417 insertions, 0 deletions
diff --git a/src/patchsets/resin/3.2.1/mod_caucho-3.2.1-gentoo.patch b/src/patchsets/resin/3.2.1/mod_caucho-3.2.1-gentoo.patch
new file mode 100644
index 0000000000..1c934a9358
--- /dev/null
+++ b/src/patchsets/resin/3.2.1/mod_caucho-3.2.1-gentoo.patch
@@ -0,0 +1,17 @@
+diff -Nru resin-3.2.1.vanilla/modules/c/src/apache2/Makefile.in resin-3.2.1/modules/c/src/apache2/Makefile.in
+--- resin-3.2.1.vanilla/modules/c/src/apache2/Makefile.in 2009-01-10 14:55:33.000000000 +0000
++++ resin-3.2.1/modules/c/src/apache2/Makefile.in 2009-02-02 23:17:34.000000000 +0000
+@@ -36,11 +36,8 @@
+ $(CC) -c $(INCLUDES) $(CFLAGS) $<
+
+ install : mod_caucho.la
+- $(LIBTOOL) --mode=install $(CP) mod_caucho.la $(apache_libexec)
+- - rm -f $(apache_libexec)/mod_caucho.la
+- - rm -f $(apache_libexec)/mod_caucho.a
+- sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
+- -resin_home $(resin_home)
++ mkdir -p $(DESTDIR)$(apache_libexec)
++ $(LIBTOOL) --mode=install $(CP) mod_caucho.la $(DESTDIR)$(apache_libexec)
+
+ clean :
+ - rm -r *.o *.lo *.la *.so .libs
diff --git a/src/patchsets/resin/3.2.1/mod_caucho-3.2.1-java.patch b/src/patchsets/resin/3.2.1/mod_caucho-3.2.1-java.patch
new file mode 100644
index 0000000000..267081f230
--- /dev/null
+++ b/src/patchsets/resin/3.2.1/mod_caucho-3.2.1-java.patch
@@ -0,0 +1,144 @@
+diff -Nru resin-3.2.1.vanilla/configure.ac resin-3.2.1/configure.ac
+--- resin-3.2.1.vanilla/configure.ac 2009-01-10 14:55:33.000000000 +0000
++++ resin-3.2.1/configure.ac 2009-02-02 23:18:45.000000000 +0000
+@@ -450,54 +450,6 @@
+ fi
+ fi
+ #
+-# --with-java-home
+-#
+-AC_ARG_WITH(java-home,
+-[ --with-java-home=DIR java home
+-], [
+-JAVA_HOME=${withval}
+-])
+-
+-if test -z "$JAVA_HOME"; then
+- java=`which java 2>/dev/null`
+- if test $? = "0"; then
+- while test -h "$java"
+- do
+- head=`dirname $java`
+- tail=`/bin/ls -l $java | awk '{ print $NF; }'`
+- if test -f "$tail"; then
+- java=$tail
+- else
+- java=$head/$tail
+- fi
+- done
+-
+- javabin=`dirname $java`
+- JAVA_HOME=`cd $javabin/..; pwd`
+-
+- # we're in $JAVA_HOME/jre
+- if test -f "$JAVA_HOME/lib/rt.jar"; then
+- JAVA_HOME=`cd $JAVA_HOME/..; pwd`
+- elif test -d "/usr/java"; then
+- JAVA_HOME=/usr/java
+- elif test -f "/System/Library/Frameworks/JavaVM.framework"; then
+- JAVA_HOME="/System/Library/Frameworks/JavaVM.framework"
+- fi
+- elif test -d "/usr/java"; then
+- JAVA_HOME=/usr/java
+- elif test -f "/System/Library/Frameworks/JavaVM.framework"; then
+- JAVA_HOME="/System/Library/Frameworks/JavaVM.framework"
+- fi
+-fi
+-
+-echo $ac_n "checking for JAVA_HOME... $JAVA_HOME"
+-
+-if test ! -d "$JAVA_HOME"; then
+- AC_MSG_ERROR([Can't find valid JAVA_HOME ${JAVA_HOME}])
+-fi
+-
+-AC_SUBST(JAVA_HOME)
+-#
+ # Resin home
+ #
+ resin_home=`pwd`
+@@ -828,85 +780,6 @@
+ AC_SUBST(SSL_LIBS)
+
+ #
+-# --with-jni-include
+-#
+-AC_ARG_WITH(jni-include,
+-[ --with-jni-include="-Idir -Idir" jni include string
+-], [
+-JNI_INCLUDE=${withval}
+-JNI="yes"
+-])
+-
+-#
+-# --enable-jni
+-#
+-AC_ARG_ENABLE(jni,
+-[ --enable-jni Turn on jni],
+-[case "${enableval}" in
+- yes) JNI=true ;;
+- no) JNI="" ;;
+- *) AC_MSG_ERROR(bad value ${enableval} for --enable-jni) ;;
+- esac],[JNI=""])
+-
+-if test -n "$JNI_INCLUDE"; then
+- JNI=yes
+-elif test -r "$JAVA_HOME/include/jni_md.h"; then
+- JNI_INCLUDE="-I$JAVA_HOME/include"
+- JNI=yes
+- echo "checking for JNI in $JAVA_HOME/include ... found"
+-elif test -r "$JAVA_HOME/include/$jni_os/jni_md.h"; then
+- JNI_INCLUDE="-I$JAVA_HOME/include -I$JAVA_HOME/include/$jni_os"
+- JNI=yes
+- echo "checking for JNI in $JAVA_HOME/include/$jni_os ... found"
+-elif test -r "/System/Library/Frameworks/JavaVM.framework/Headers/jni_md.h"; then
+- # Darwin
+- echo "checking for JNI in /System/Library/Frameworks/JavaVM.framework/Headers ... found"
+- JNI_INCLUDE="-I/System/Library/Frameworks/JavaVM.framework/Headers"
+- JNI=yes
+-elif test -r "$JAVA_HOME/../Headers/jni_md.h"; then
+- # Darwin
+- echo "checking for JNI in $JAVA_HOME/../Headers ... found"
+- JNI_INCLUDE="-I$JAVA_HOME/../Headers"
+- JNI=yes
+-elif test -r "$JAVA_HOME/include/jni.h"; then
+- JNI_INCLUDE="-I$JAVA_HOME/include"
+- JNI=yes
+- echo "checking for JNI in $JAVA_HOME/include ... found"
+-else
+- JNI=""
+- AC_MSG_WARN([Can't find JNI directory ${JAVA_HOME}/include/$jni_os])
+-fi
+-
+-if test -r "$JAVA_HOME/include/jvmti.h"; then
+- echo "Using JVMTI for class reloading"
+-
+- CFLAGS="$CFLAGS -DHAS_JVMTI"
+-elif test -r "$JAVA_HOME/../Headers/jvmti.h"; then
+- echo "Using JVMTI for class reloading"
+-
+- CFLAGS="$CFLAGS -DHAS_JVMTI"
+-fi
+-
+-if test -r "$JAVA_HOME/include/jvmdi.h"; then
+- echo "Using JVMDI for class reloading"
+-
+- CFLAGS="$CFLAGS -DHAS_JVMDI"
+-elif test -r "$JAVA_HOME/../Headers/jvmdi.h"; then
+- echo "Using JVMDI for class reloading"
+-
+- CFLAGS="$CFLAGS -DHAS_JVMDI"
+-fi
+-
+-if test -n "$JNI"; then
+- plugins="$plugins resin_os $resin_plugin"
+-else
+- echo "Can't JNI include files in JAVA_HOME: $JAVA_HOME"
+-fi
+-
+-AC_SUBST(JNI)
+-AC_SUBST(JNI_INCLUDE)
+-
+-#
+ # --enable-ssl
+ #
+ AC_ARG_ENABLE(ssl,
diff --git a/src/patchsets/resin/3.2.1/mod_caucho-3.2.1-ssl.patch b/src/patchsets/resin/3.2.1/mod_caucho-3.2.1-ssl.patch
new file mode 100644
index 0000000000..4bfbcc5262
--- /dev/null
+++ b/src/patchsets/resin/3.2.1/mod_caucho-3.2.1-ssl.patch
@@ -0,0 +1,20 @@
+diff -Nru resin-3.2.1.vanilla/modules/c/src/apache2/mod_caucho.c resin-3.2.1/modules/c/src/apache2/mod_caucho.c
+--- resin-3.2.1.vanilla/modules/c/src/apache2/mod_caucho.c 2009-01-10 14:55:33.000000000 +0000
++++ resin-3.2.1/modules/c/src/apache2/mod_caucho.c 2009-02-02 23:22:19.000000000 +0000
+@@ -627,6 +627,16 @@
+ }
+ }
+ }
++ /* Add SSL Client certificate: (requires SSLOptions +StdEnvVars) */
++ {
++ int i;
++ char **env = (char **)ap_create_environment(r->pool, r->subprocess_env);
++ for (i = 0; env[i]; ++i) {
++ char *name = strsep(&(env[i]), "=");
++ if (strncmp(name, "SSL_CLIENT_CERT", 16) == 0)
++ cse_write_string(s, CSE_CLIENT_CERT, env[i]);
++ }
++ }
+ }
+
+ /**
diff --git a/src/patchsets/resin/3.2.1/resin-3.2.1-Makefile.am.patch b/src/patchsets/resin/3.2.1/resin-3.2.1-Makefile.am.patch
new file mode 100644
index 0000000000..8757b7fe07
--- /dev/null
+++ b/src/patchsets/resin/3.2.1/resin-3.2.1-Makefile.am.patch
@@ -0,0 +1,40 @@
+--- resin-3.2.1.vanilla/Makefile.am 2009-01-10 14:55:35.000000000 +0000
++++ resin-3.2.1/Makefile.am 2009-02-02 19:37:41.000000000 +0000
+@@ -9,21 +9,21 @@
+
+ install :
+ (cd modules/c/src; $(MAKE) install)
+- if test $(PREFIX) != `pwd`; then \
+- mkdir -p $(PREFIX)/lib; \
+- mkdir -p $(PREFIX)/$(LIBEXEC); \
+- cp -r $(LIBEXEC)/* $(PREFIX)/$(LIBEXEC); \
+- cp lib/*.jar $(PREFIX)/lib; \
+- mkdir -p $(PREFIX)/bin; \
+- cp bin/* $(PREFIX)/bin; \
+- mkdir -p $(PREFIX)/webapps; \
+- cp -r webapps/* $(PREFIX)/webapps; \
+- mkdir -p $(PREFIX)/doc; \
+- cp -r doc/* $(PREFIX)/doc; \
+- mkdir -p $(PREFIX)/conf; \
+- cp conf/app-default.xml $(PREFIX)/conf/app-default.xml.orig; \
+- if test ! -r $(PREFIX)/conf/resin.xml; then \
+- cp conf/resin.xml $(PREFIX)/conf/resin.xml; \
+- cp conf/app-default.xml $(PREFIX)/conf/app-default.xml; \
++ if test $(DESTDIR)/$(PREFIX) != `pwd`; then \
++ mkdir -p $(DESTDIR)/$(PREFIX)/lib; \
++ mkdir -p $(DESTDIR)/$(PREFIX)/$(LIBEXEC); \
++ cp -r $(LIBEXEC)/* $(DESTDIR)/$(PREFIX)/$(LIBEXEC); \
++ cp lib/*.jar $(DESTDIR)/$(PREFIX)/lib; \
++ mkdir -p $(DESTDIR)/$(PREFIX)/bin; \
++ cp bin/* $(DESTDIR)/$(PREFIX)/bin; \
++ mkdir -p $(DESTDIR)/$(PREFIX)/webapps; \
++ cp -r webapps/* $(DESTDIR)/$(PREFIX)/webapps; \
++ mkdir -p $(DESTDIR)/$(PREFIX)/doc; \
++ cp -r doc/* $(DESTDIR)/$(PREFIX)/doc; \
++ mkdir -p $(DESTDIR)/$(PREFIX)/conf; \
++ cp conf/app-default.xml $(DESTDIR)/$(PREFIX)/conf/app-default.xml.orig; \
++ if test ! -r $(DESTDIR)/$(PREFIX)/conf/resin.xml; then \
++ cp conf/resin.xml $(DESTDIR)/$(PREFIX)/conf/resin.xml; \
++ cp conf/app-default.xml $(DESTDIR)/$(PREFIX)/conf/app-default.xml; \
+ fi; \
+ fi
diff --git a/src/patchsets/resin/3.2.1/resin-3.2.1-build.xml.patch b/src/patchsets/resin/3.2.1/resin-3.2.1-build.xml.patch
new file mode 100644
index 0000000000..0bd82da569
--- /dev/null
+++ b/src/patchsets/resin/3.2.1/resin-3.2.1-build.xml.patch
@@ -0,0 +1,196 @@
+diff -Nru resin-3.2.1.vanilla/build-common.xml resin-3.2.1/build-common.xml
+--- resin-3.2.1.vanilla/build-common.xml 2009-01-10 14:55:35.000000000 +0000
++++ resin-3.2.1/build-common.xml 2009-02-02 22:59:37.000000000 +0000
+@@ -3,7 +3,7 @@
+
+ <property file="local.properties"/>
+
+- <property name="resindir" location="${basedir}/../resin"/>
++ <property name="resindir" location="${basedir}"/>
+ <property name="prodir" location="${basedir}/../pro"/>
+
+ <property name="install" location="${basedir}/"/>
+@@ -16,7 +16,6 @@
+ <property name="resin.artifacts" location="${resindir}/artifacts"/>
+
+ <property name="src" location="${basedir}/src"/>
+- <property name="ext" location="${resindir}/modules/ext"/>
+ <property name="ivy.lib" location="${resindir}/ivy-lib"/>
+ <property name="doc" location="${resindir}/doc"/>
+
+@@ -34,15 +33,12 @@
+ <property name="resin.dist" location="${resin.install}/dist"/>
+
+ <property name="javac.verbose" value="off"/>
+- <property name="javac.debug" value="on"/>
+- <property name="javac.optimize" value="off"/>
++ <property name="javac.debug" value="off"/>
++ <property name="javac.optimize" value="on"/>
+ <property name="javac.deprecation" value="off"/>
+ <property name="javac.nowarn" value="on"/>
+ <property name="javac.memoryMaximumSize" value="512m"/>
+
+- <property name="javac.source" value="1.5"/>
+- <property name="javac.target" value="1.5"/>
+-
+ <property name="jar.compress" value="false"/>
+ <!--
+ <property name="jar.index" value="true"/>
+@@ -161,8 +157,6 @@
+ verbose="${javac.verbose}"
+ debug="${javac.debug}" optimize="${javac.optimize}"
+ deprecation="${javac.deprecation}" nowarn="${javac.nowarn}"
+- source="${javac.source}"
+- target="${javac.target}"
+ excludes="**/.svn/**"
+ memoryMaximumSize="${javac.memoryMaximumSize}">
+ <classpath>
+@@ -172,10 +166,10 @@
+ <dirset dir="${modules}">
+ <include name="*/classes"/>
+ </dirset>
+- <fileset dir="${ext}">
++ <fileset dir="${ivy.lib}">
+ <include name="**/*.jar"/>
+ </fileset>
+- <fileset dir="${ivy.lib}">
++ <fileset dir="${resindir}/lib">
+ <include name="**/*.jar"/>
+ </fileset>
+ </classpath>
+@@ -229,8 +223,6 @@
+ verbose="${javac.verbose}"
+ debug="${javac.debug}" optimize="${javac.optimize}"
+ deprecation="${javac.deprecation}" nowarn="${javac.nowarn}"
+- source="${javac.source}"
+- target="${javac.target}"
+ excludes="**/.svn/**"
+ memoryMaximumSize="${javac.memoryMaximumSize}">
+ <classpath>
+@@ -240,10 +232,10 @@
+ <fileset dir="${artifacts}/${artifact.name}">
+ <include name="lib/**/*.jar"/>
+ </fileset>
+- <fileset dir="${ext}">
++ <fileset dir="${ivy.lib}">
+ <include name="**/*.jar"/>
+ </fileset>
+- <fileset dir="${ivy.lib}">
++ <fileset dir="${resindir}/lib">
+ <include name="**/*.jar"/>
+ </fileset>
+ </classpath>
+@@ -330,9 +322,6 @@
+ <dirset dir="${modules}">
+ <include name="*/classes"/>
+ </dirset>
+- <fileset dir="${modules}/ext">
+- <include name="**/*.jar"/>
+- </fileset>
+ </classpath>
+ </java>
+
+@@ -439,10 +428,6 @@
+ <exclude name="**/.*"/>
+ </fileset>
+
+- <fileset dir="${resin.modules}/jsdk/classes">
+- <exclude name="**/.*"/>
+- </fileset>
+-
+ <!--
+ <fileset dir="${resin.modules}/jsf/classes">
+ <exclude name="**/.*"/>
+diff -Nru resin-3.2.1.vanilla/build.xml resin-3.2.1/build.xml
+--- resin-3.2.1.vanilla/build.xml 2009-01-10 14:55:35.000000000 +0000
++++ resin-3.2.1/build.xml 2009-02-02 22:59:55.000000000 +0000
+@@ -9,7 +9,7 @@
+ <property name="shell" value="bash"/>
+
+ <target name="compile"
+- depends="init, hessian, javaee, jaxstream, jcache, jsf, portlet, script, resin-util, quercus, resin, ecmascript, webbeans, webutil, conf, ext">
++ depends="init, hessian, javaee, jaxstream, jcache, jsf, portlet, script, resin-util, quercus, resin, ecmascript, webbeans, webutil, conf">
+ </target>
+
+ <!--
+@@ -161,7 +161,7 @@
+ </antcall>
+ </target>
+
+- <target name="hessian" depends="init, jsdk">
++ <target name="hessian" depends="init">
+ <antcall target="module" inheritRefs="true">
+ <param name="module.name" value="hessian"/>
+ <param name="module.jar" value="hessian.jar"/>
+@@ -183,7 +183,7 @@
+ </antcall>
+ </target>
+
+- <target name="jaxrpc" depends="init,saaj,jsdk">
++ <target name="jaxrpc" depends="init,saaj">
+ <antcall target="module" inheritRefs="true">
+ <param name="module.name" value="jaxrpc"/>
+ <param name="module.jar" value="jaxrpc-15.jar"/>
+@@ -245,7 +245,7 @@
+ </antcall>
+ </target>
+
+- <target name="jstl" depends="init, jsdk">
++ <target name="jstl" depends="init">
+ <antcall target="module" inheritRefs="true">
+ <param name="module.name" value="jstl"/>
+ <param name="module.jar" value="jstl-11.jar"/>
+@@ -435,7 +435,7 @@
+ </copy>
+ </target>
+
+- <target name="javaee" depends="ejb, jca, jms, jpa, jsdk, jstl, jta, jws, webbeans">
++ <target name="javaee" depends="ejb, jca, jms, jpa, jstl, jta, jws, webbeans">
+ <!--
+ - javaee-16.jar
+ -->
+@@ -456,10 +456,6 @@
+ <exclude name="**/.*"/>
+ </fileset>
+
+- <fileset dir="${resin.modules}/jsdk/classes">
+- <exclude name="**/.*"/>
+- </fileset>
+-
+ <!--
+ <fileset dir="${resin.modules}/jsf/classes">
+ <exclude name="**/.*"/>
+@@ -618,24 +614,16 @@
+ </copy>
+ </target>
+
+- <target name="ext" depends="init, resin">
+- <copy todir="${install}/lib" preservelastmodified="true">
+- <fileset dir="${ext}">
+- </fileset>
+- </copy>
+- </target>
+-
+ <target name="webapps" depends="init, doc, quercus">
+ </target>
+
+ <target name="doc" depends="init">
+ <mkdir dir="${install}/webapps"/>
+
+- <!--
+ <jar jarfile="${install}/webapps/resin-doc.war"
+ compress="true" index="${jar.index}" update="${jar.update}">
+
+- <fileset dir="doc">
++ <fileset dir="doc/resin-doc">
+ <exclude name="**/WEB-INF/work/**"/>
+ <exclude name="**/WEB-INF/pre_work/**"/>
+ <exclude name="**/WEB-INF/db/**"/>
+@@ -645,7 +633,6 @@
+ <exclude name="**/.svnignore"/>
+ </fileset>
+ </jar>
+- -->
+ </target>
+
+ <target name="javadoc" depends="init">