summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-02-24 14:37:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-02-24 14:37:08 +0000
commit7719a0d6003d5bb2a338f0e4a9602866427ab68e (patch)
tree2912a07e1bc86b1d219aedb9011a144c9275d050 /src/patchsets/rezound
parentrezound patchset (diff)
downloadgentoo-7719a0d6003d5bb2a338f0e4a9602866427ab68e.tar.gz
gentoo-7719a0d6003d5bb2a338f0e4a9602866427ab68e.tar.bz2
gentoo-7719a0d6003d5bb2a338f0e4a9602866427ab68e.zip
rezound patchset for the new release
Diffstat (limited to 'src/patchsets/rezound')
-rw-r--r--src/patchsets/rezound/0.12.3_beta/010_all_flac-1.1.3.patch101
-rw-r--r--src/patchsets/rezound/0.12.3_beta/020_all_64bits.patch68
-rw-r--r--src/patchsets/rezound/0.12.3_beta/030_all_dont-ignore-cxxflags.patch13
-rw-r--r--src/patchsets/rezound/0.12.3_beta/040_all_automagic.patch54
-rw-r--r--src/patchsets/rezound/0.12.3_beta/series4
5 files changed, 240 insertions, 0 deletions
diff --git a/src/patchsets/rezound/0.12.3_beta/010_all_flac-1.1.3.patch b/src/patchsets/rezound/0.12.3_beta/010_all_flac-1.1.3.patch
new file mode 100644
index 0000000000..2854f83880
--- /dev/null
+++ b/src/patchsets/rezound/0.12.3_beta/010_all_flac-1.1.3.patch
@@ -0,0 +1,101 @@
+Index: rezound-0.12.3beta/src/backend/CFLACSoundTranslator.cpp
+===================================================================
+--- rezound-0.12.3beta.orig/src/backend/CFLACSoundTranslator.cpp
++++ rezound-0.12.3beta/src/backend/CFLACSoundTranslator.cpp
+@@ -42,6 +42,12 @@
+ #include "CSound.h"
+ #include "AStatusComm.h"
+
++#if !defined(FLAC_API_VERSION_CURRENT) || FLAC_API_VERSION_CURRENT < 8
++#define LEGACY_FLAC
++#else
++#undef LEGACY_FLAC
++#endif
++
+ CFLACSoundTranslator::CFLACSoundTranslator()
+ {
+ }
+@@ -75,15 +81,23 @@ public:
+ for(unsigned t=0;t<MAX_CHANNELS;t++)
+ accessers[t]=NULL;
+
++#ifdef LEGACY_FLAC
+ set_filename(filename.c_str());
++#endif
+
+ set_metadata_ignore_all();
+ //set_metadata_respond(FLAC__METADATA_TYPE_VORBIS_COMMENT);
+ //set_metadata_respond(FLAC__METADATA_TYPE_CUESHEET);
+
++#ifdef LEGACY_FLAC
+ State s=init();
+ if(s!=FLAC__FILE_DECODER_OK)
+ throw runtime_error(string(__func__)+" -- "+s.as_cstring());
++#else
++ FLAC__StreamDecoderInitStatus s=init(filename.c_str());
++ if(s!=FLAC__STREAM_DECODER_INIT_STATUS_OK)
++ throw runtime_error(string(__func__)+" -- FLAC__STREAM_DECODER_INIT_STATUS not OK");
++#endif
+ }
+
+ virtual ~MyFLACDecoderFile()
+@@ -170,7 +184,11 @@ protected:
+
+ // update status bar and detect user cancel
+ FLAC__uint64 filePosition;
++#ifdef LEGACY_FLAC
+ FLAC__file_decoder_get_decode_position(decoder_, &filePosition);
++#else
++ FLAC__stream_decoder_get_decode_position(decoder_, &filePosition);
++#endif
+ return statusBar.update(filePosition) ? FLAC__STREAM_DECODER_WRITE_STATUS_ABORT : FLAC__STREAM_DECODER_WRITE_STATUS_CONTINUE;
+ }
+
+@@ -215,7 +233,11 @@ private:
+ bool CFLACSoundTranslator::onLoadSound(const string filename,CSound *sound) const
+ {
+ MyFLACDecoderFile f(filename,sound);
++#ifdef LEGACY_FLAC
+ return f.process_until_end_of_file();
++#else
++ return f.process_until_end_of_stream();
++#endif
+ }
+
+
+@@ -258,7 +280,9 @@ bool CFLACSoundTranslator::onSaveSound(c
+
+ MyFLACEncoderFile f(saveLength);
+
++#ifdef LEGACY_FLAC
+ f.set_filename(filename.c_str());
++#endif
+
+ f.set_channels(sound->getChannelCount());
+
+@@ -274,8 +298,13 @@ bool CFLACSoundTranslator::onSaveSound(c
+ //f.set_metadata(...) // ??? to do to set cues and user notes, etc
+
+
++#ifdef LEGACY_FLAC
+ MyFLACEncoderFile::State s=f.init();
+ if(s==FLAC__STREAM_ENCODER_OK)
++#else
++ FLAC__StreamEncoderInitStatus s=f.init(filename.c_str());
++ if(s==FLAC__STREAM_ENCODER_INIT_STATUS_OK)
++#endif
+ {
+ #define BUFFER_SIZE 65536
+ TAutoBuffer<FLAC__int32> buffers[MAX_CHANNELS];
+@@ -328,7 +357,11 @@ bool CFLACSoundTranslator::onSaveSound(c
+ return true;
+ }
+ else
++#ifdef LEGACY_FLAC
+ throw runtime_error(string(__func__)+" -- error creating FLAC encoder -- "+s.as_cstring());
++#else
++ throw runtime_error(string(__func__)+" -- error creating FLAC encoder -- ");
++#endif
+
+ }
+
diff --git a/src/patchsets/rezound/0.12.3_beta/020_all_64bits.patch b/src/patchsets/rezound/0.12.3_beta/020_all_64bits.patch
new file mode 100644
index 0000000000..6a738ae50f
--- /dev/null
+++ b/src/patchsets/rezound/0.12.3_beta/020_all_64bits.patch
@@ -0,0 +1,68 @@
+Index: rezound-0.12.3beta/src/frontend_fox/CMainWindow.cpp
+===================================================================
+--- rezound-0.12.3beta.orig/src/frontend_fox/CMainWindow.cpp
++++ rezound-0.12.3beta/src/frontend_fox/CMainWindow.cpp
+@@ -438,7 +438,7 @@ void CMainWindow::rebuildSoundWindowList
+
+ long CMainWindow::onSoundListChange(FXObject *sender,FXSelector sel,void *ptr)
+ {
+- FXint index=(FXint)ptr;
++ FXint index=(long)ptr;
+
+ if(index>=0 && index<soundList->getNumItems())
+ {
+@@ -1853,13 +1853,13 @@ long CMainWindow::onKeyboardShuttle(FXOb
+
+ if(pos==0 && FXSELID(sel)==ID_SHUTTLE_BACKWARD)
+ {
+- if((unsigned)ptr > 1/*came from keyboard event*/) enableAutoRepeat(getApp()->getDisplay(),false); // QQQ
++ if((long)ptr > 1/*came from keyboard event*/) enableAutoRepeat(getApp()->getDisplay(),false); // QQQ
+ shuttleDial->setValue(pos-inc);
+ onShuttleChange(sender,sel,ptr);
+ }
+ else if(pos==0 && FXSELID(sel)==ID_SHUTTLE_FORWARD)
+ {
+- if((unsigned)ptr > 1/*came from keyboard event*/) enableAutoRepeat(getApp()->getDisplay(),false); // QQQ
++ if((long)ptr > 1/*came from keyboard event*/) enableAutoRepeat(getApp()->getDisplay(),false); // QQQ
+ shuttleDial->setValue(pos+inc);
+ onShuttleChange(sender,sel,ptr);
+ }
+Index: rezound-0.12.3beta/src/frontend_fox/CMp3Dialog.cpp
+===================================================================
+--- rezound-0.12.3beta.orig/src/frontend_fox/CMp3Dialog.cpp
++++ rezound-0.12.3beta/src/frontend_fox/CMp3Dialog.cpp
+@@ -170,7 +170,7 @@ template <class type> void setEnable(typ
+
+ long CMp3Dialog::onRadioButton(FXObject *sender,FXSelector sel,void *ptr)
+ {
+- if((int)ptr==0) // only act when ptr==1 when it's getting checked
++ if((long)ptr==0) // only act when ptr==1 when it's getting checked
+ return 1;
+
+ // turn off all buttons
+Index: rezound-0.12.3beta/src/frontend_fox/COggDialog.cpp
+===================================================================
+--- rezound-0.12.3beta.orig/src/frontend_fox/COggDialog.cpp
++++ rezound-0.12.3beta/src/frontend_fox/COggDialog.cpp
+@@ -136,7 +136,7 @@ template <class type> void setEnable(typ
+
+ long COggDialog::onRadioButton(FXObject *sender,FXSelector sel,void *ptr)
+ {
+- if((int)ptr==0) // only act when ptr==1 when it's getting checked
++ if((long)ptr==0) // only act when ptr==1 when it's getting checked
+ return 1;
+
+ // turn off all buttons
+Index: rezound-0.12.3beta/src/frontend_fox/CPasteChannelsDialog.cpp
+===================================================================
+--- rezound-0.12.3beta.orig/src/frontend_fox/CPasteChannelsDialog.cpp
++++ rezound-0.12.3beta/src/frontend_fox/CPasteChannelsDialog.cpp
+@@ -206,7 +206,7 @@ bool CPasteChannelsDialog::show(CActionS
+ {
+ pasteChannels.clear();
+
+- actionParameters->setValue<unsigned>(_("MixMethod"),(unsigned)(mixTypeComboBox->getItemData(mixTypeComboBox->getCurrentItem())));
++ actionParameters->setValue<unsigned>(_("MixMethod"),(long)(mixTypeComboBox->getItemData(mixTypeComboBox->getCurrentItem())));
+
+ if(repeatTypeComboBox->getCurrentItem()==0)
+ { // repeating it a given number of times
diff --git a/src/patchsets/rezound/0.12.3_beta/030_all_dont-ignore-cxxflags.patch b/src/patchsets/rezound/0.12.3_beta/030_all_dont-ignore-cxxflags.patch
new file mode 100644
index 0000000000..55d3ae368e
--- /dev/null
+++ b/src/patchsets/rezound/0.12.3_beta/030_all_dont-ignore-cxxflags.patch
@@ -0,0 +1,13 @@
+Index: rezound-0.12.3beta/configure.ac
+===================================================================
+--- rezound-0.12.3beta.orig/configure.ac
++++ rezound-0.12.3beta/configure.ac
+@@ -53,7 +53,7 @@ AC_LANG(C++)
+ ############################################################################
+ # Checks for programs #
+ ############################################################################
+-CXXFLAGS= # AC_PROG_CXX automatically sets CXXFLAGS to -g -O2 if g++ is the C++ compiler and CXXFLAGS hasn't been set, so by setting CXXFLAGS, we can avoid this.
++CXXFLAGS="$CXXFLAGS" # AC_PROG_CXX automatically sets CXXFLAGS to -g -O2 if g++ is the C++ compiler and CXXFLAGS hasn't been set, so by setting CXXFLAGS, we can avoid this.
+ AC_PROG_CXX
+ AC_PROG_AWK
+ AC_PROG_CC
diff --git a/src/patchsets/rezound/0.12.3_beta/040_all_automagic.patch b/src/patchsets/rezound/0.12.3_beta/040_all_automagic.patch
new file mode 100644
index 0000000000..149d6adcfc
--- /dev/null
+++ b/src/patchsets/rezound/0.12.3_beta/040_all_automagic.patch
@@ -0,0 +1,54 @@
+Index: rezound-0.12.3beta/configure.ac
+===================================================================
+--- rezound-0.12.3beta.orig/configure.ac
++++ rezound-0.12.3beta/configure.ac
+@@ -505,12 +505,17 @@ AM_PATH_AUDIOFILE(0.2.2,AC_DEFINE(HAVE_L
+ AC_LANG_PUSH(C) # xiph needs to include vorbisenc.h as well if C++ is going to compile the code
+
+ AH_TEMPLATE(HAVE_LIBOGG)
+-# this macro detects libogg and does an AC_SUBST on OGG_CFLAGS and OGG_LIBS, so I put these variables in src/backend/Makefile.am for substitution
++AC_ARG_ENABLE(vorbis, AC_HELP_STRING([--disable-vorbis], [disable support for vorbis (default=autodetect)]), [ enable_vorbis=$enableval ], [ enable_vorbis=yes ])
++# this macro detects libogg and does an AC_SUBST on OGG_CFLAGS and OGG_LIBS, so I put these variables in src/backend/Makefile.am for substitutioni
++if test "x$enable_vorbis" = "xyes"; then
+ XIPH_PATH_OGG(AC_DEFINE(HAVE_LIBOGG),AC_MSG_NOTICE([Ogg Vorbis website: http://www.xiph.org]))
++fi
+
+ AH_TEMPLATE(HAVE_LIBVORBIS)
+ # this macro detects libvorbis and does an AC_SUBST on VORBIS_CFLAGS, VORBIS_LIBS, VORBISFILE_LIBS and VORBISENC_LIBS, so I put these variables in src/backend/Makefile.am for substitution
++if test "x$enable_vorbis" = "xyes"; then
+ XIPH_PATH_VORBIS(AC_DEFINE(HAVE_LIBVORBIS),AC_MSG_NOTICE([Ogg Vorbis website: http://www.xiph.org]))
++fi
+
+ AC_LANG_POP(C)
+
+@@ -524,7 +529,9 @@ AC_LANG_POP(C)
+ AH_TEMPLATE(HAVE_LIBFLACPP)
+ AH_TEMPLATE(HAVE_LIBFLAC)
+
++AC_ARG_ENABLE(flac, AC_HELP_STRING([--disable-flac], [disable support for flac (default=autodetect)]), [ enable_flac=$enableval ], [ enable_flac=yes ])
+ # look for libFLAC and if it's found then look for libFLAC++
++if test "x$enable_flac" = "xyes"; then
+ AM_PATH_LIBFLAC(
+ [
+ AC_DEFINE(HAVE_LIBFLAC)
+@@ -532,7 +539,7 @@ AM_PATH_LIBFLAC(
+ ],
+ AC_MSG_NOTICE([FLAC website: http://flac.sourceforge.net])
+ )
+-
++fi
+
+
+
+@@ -603,8 +610,10 @@ AC_SUBST(MAYBE_LADSPA_LIB)
+ dnl ############################################################################
+ dnl # Handle the flags for a library to to tempo/pitch changing independantly *
+ dnl ############################################################################
++AC_ARG_ENABLE(soundtouch, AC_HELP_STRING([--disable-soundtouch], [disable support for soundtouch (default=autodetect)]), [ enable_soundtouch=$enableval ], [ enable_soundtouch=yes ])
++if test "x$enable_soundtouch" = "xyes"; then
+ AM_PATH_SOUNDTOUCH([],[],AC_MSG_WARN([***** libSoundTouch not found -- tempo and pitch changing will be disabled (http://www.iki.fi/oparviai/soundtouch) *****]))
+-
++fi
+
+
+
diff --git a/src/patchsets/rezound/0.12.3_beta/series b/src/patchsets/rezound/0.12.3_beta/series
new file mode 100644
index 0000000000..3bf415d456
--- /dev/null
+++ b/src/patchsets/rezound/0.12.3_beta/series
@@ -0,0 +1,4 @@
+010_all_flac-1.1.3.patch
+020_all_64bits.patch
+030_all_dont-ignore-cxxflags.patch
+040_all_automagic.patch