summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-02-04 12:35:46 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-02-04 12:35:46 +0000
commit0e1f281479fe90f21ddc769d2e9a1d3b4c68ba66 (patch)
tree5d9087a49a8ea9918693e4f3d5a4910a9e59b192
parentVersion bump, fixes bug 382077 by needle <qui_wan_chong@yahoo.de> (diff)
downloadgentoo-2-0e1f281479fe90f21ddc769d2e9a1d3b4c68ba66.tar.gz
gentoo-2-0e1f281479fe90f21ddc769d2e9a1d3b4c68ba66.tar.bz2
gentoo-2-0e1f281479fe90f21ddc769d2e9a1d3b4c68ba66.zip
Utilize new app-admin/eselect-opencl and the fact that we now have 3 viable providers, use flags are no longer mutually exclusive
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64, RepoMan options: --force)
-rw-r--r--virtual/opencl/ChangeLog11
-rw-r--r--virtual/opencl/metadata.xml4
-rw-r--r--virtual/opencl/opencl-0-r1.ebuild20
3 files changed, 33 insertions, 2 deletions
diff --git a/virtual/opencl/ChangeLog b/virtual/opencl/ChangeLog
index 7de2a68d8436..1328f62cf079 100644
--- a/virtual/opencl/ChangeLog
+++ b/virtual/opencl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for virtual/opencl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/ChangeLog,v 1.2 2011/12/20 22:09:15 vapier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/ChangeLog,v 1.3 2012/02/04 12:35:46 xarthisius Exp $
+
+*opencl-0-r1 (04 Feb 2012)
+
+ 04 Feb 2012; Kacper Kowalik <xarthisius@gentoo.org> +opencl-0-r1.ebuild,
+ metadata.xml:
+ Utilize new app-admin/eselect-opencl and the fact that we now have 3 viable
+ providers, use flags are no longer mutually exclusive
20 Dec 2011; Mike Frysinger <vapier@gentoo.org> opencl-0.ebuild:
Drop ATI from dep list for now since that only provides the libraries and not
diff --git a/virtual/opencl/metadata.xml b/virtual/opencl/metadata.xml
index 01c4c004e735..81cbff6425ed 100644
--- a/virtual/opencl/metadata.xml
+++ b/virtual/opencl/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>x11</herd>
+<maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+</maintainer>
</pkgmetadata>
diff --git a/virtual/opencl/opencl-0-r1.ebuild b/virtual/opencl/opencl-0-r1.ebuild
new file mode 100644
index 000000000000..e137c78acd87
--- /dev/null
+++ b/virtual/opencl/opencl-0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/opencl/opencl-0-r1.ebuild,v 1.1 2012/02/04 12:35:46 xarthisius Exp $
+
+EAPI="4"
+
+DESCRIPTION="Virtual for OpenCL implementations"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+CARDS=( fglrx nvidia )
+IUSE="${CARDS[@]/#/video_cards_}"
+
+DEPEND=""
+RDEPEND="app-admin/eselect-opencl
+ || (
+ video_cards_fglrx? ( >=x11-drivers/ati-drivers-12.1[opencl] )
+ video_cards_nvidia? ( >=x11-drivers/nvidia-drivers-290.10 )
+ dev-util/intel-ocl-sdk
+ )"