summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-10-17 18:54:14 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-10-17 18:54:14 +0000
commit11dc9da4451703ae37303777eefc5044bc8474f3 (patch)
tree59e1d58bfaea39cc88188486fff291725a4be161
parent* bug #109587 (diff)
downloadgentoo-2-11dc9da4451703ae37303777eefc5044bc8474f3.tar.gz
gentoo-2-11dc9da4451703ae37303777eefc5044bc8474f3.tar.bz2
gentoo-2-11dc9da4451703ae37303777eefc5044bc8474f3.zip
Added word/byte type fix for new pciutils.
(Portage version: 2.0.53_rc5)
-rw-r--r--x11-misc/Xorgautoconfig/ChangeLog6
-rw-r--r--x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.1.ebuild5
-rw-r--r--x11-misc/Xorgautoconfig/files/pciutils.patch29
3 files changed, 37 insertions, 3 deletions
diff --git a/x11-misc/Xorgautoconfig/ChangeLog b/x11-misc/Xorgautoconfig/ChangeLog
index 0bb101171e3d..ff7fdb0a8833 100644
--- a/x11-misc/Xorgautoconfig/ChangeLog
+++ b/x11-misc/Xorgautoconfig/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/Xorgautoconfig
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/Xorgautoconfig/ChangeLog,v 1.5 2005/10/02 16:27:35 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/Xorgautoconfig/ChangeLog,v 1.6 2005/10/17 18:54:14 josejx Exp $
+
+ 17 Oct 2005; Joseph Jezak <josejx@gentoo.org> +files/pciutils.patch,
+ Xorgautoconfig-0.2.1.ebuild:
+ Added word/byte type fix for new pciutils.
02 Oct 2005; Joseph Jezak <josejx@gentoo.org> Xorgautoconfig-0.2.1.ebuild:
Marked ppc stable.
diff --git a/x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.1.ebuild b/x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.1.ebuild
index 85c810653d83..6bed62b65e14 100644
--- a/x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.1.ebuild
+++ b/x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.1.ebuild,v 1.2 2005/10/02 16:27:35 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/Xorgautoconfig/Xorgautoconfig-0.2.1.ebuild,v 1.3 2005/10/17 18:54:14 josejx Exp $
-inherit toolchain-funcs
+inherit eutils toolchain-funcs
DESCRIPTION="Xorgautconfig generates xorg.conf files for PPC based computers."
HOMEPAGE="http://ppc.gentoo.org"
@@ -19,6 +19,7 @@ RDEPEND="sys-apps/pciutils"
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/pciutils.patch
sed -i -e "/^CC=/s:gcc:$(tc-getCC):" Makefile || die "Can't replace CC"
}
diff --git a/x11-misc/Xorgautoconfig/files/pciutils.patch b/x11-misc/Xorgautoconfig/files/pciutils.patch
new file mode 100644
index 000000000000..37d577a02494
--- /dev/null
+++ b/x11-misc/Xorgautoconfig/files/pciutils.patch
@@ -0,0 +1,29 @@
+--- pci.c 2005-07-20 16:12:35.000000000 -0400
++++ /usr/local/cvs/gentoo-src/Xorgautoconfig/pci.c 2005-10-17 14:15:29.000000000 -0400
+@@ -24,7 +24,7 @@
+ struct device *next;
+ struct pci_dev *dev;
+ unsigned int config_cnt;
+- byte config[256];
++ u8 config[256];
+ };
+
+ struct device *first_dev;
+@@ -67,7 +67,7 @@
+ }
+ }
+
+-word get_conf_word(struct device *d, unsigned int pos)
++u16 get_conf_word(struct device *d, unsigned int pos)
+ {
+ return d->config[pos] | (d->config[pos+1] << 8);
+ }
+@@ -76,7 +76,7 @@
+ {
+ struct device *d;
+ struct pci_dev *p;
+- word w;
++ u16 w;
+
+ pacc = pci_alloc();
+ pci_filter_init(pacc, &filter);