summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-12-22 11:02:28 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-12-22 11:02:28 +0000
commit147eee75478be9e1eb4baea076218e5b7e371641 (patch)
tree3b8b380f804ce40202055b4aecd0559ecc5ba31e
parentcorrected Manifest (diff)
downloadgentoo-2-147eee75478be9e1eb4baea076218e5b7e371641.tar.gz
gentoo-2-147eee75478be9e1eb4baea076218e5b7e371641.tar.bz2
gentoo-2-147eee75478be9e1eb4baea076218e5b7e371641.zip
Compile nvclock with -fPIC, bug #111675.
(Portage version: 2.0.53)
-rw-r--r--sys-power/cpufreqd/ChangeLog6
-rw-r--r--sys-power/cpufreqd/cpufreqd-2.0.0.ebuild3
-rw-r--r--sys-power/cpufreqd/files/nvclock0.8b-fpic.patch13
3 files changed, 20 insertions, 2 deletions
diff --git a/sys-power/cpufreqd/ChangeLog b/sys-power/cpufreqd/ChangeLog
index 95e5464c1f49..4f6d5f266f69 100644
--- a/sys-power/cpufreqd/ChangeLog
+++ b/sys-power/cpufreqd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/cpufreqd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.22 2005/11/27 09:46:06 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/ChangeLog,v 1.23 2005/12/22 11:02:28 brix Exp $
+
+ 22 Dec 2005; Henrik Brix Andersen <brix@gentoo.org>
+ +files/nvclock0.8b-fpic.patch, cpufreqd-2.0.0.ebuild:
+ Compile nvclock with -fPIC, bug #111675.
*cpufreqd-2.0.0 (27 Nov 2005)
diff --git a/sys-power/cpufreqd/cpufreqd-2.0.0.ebuild b/sys-power/cpufreqd/cpufreqd-2.0.0.ebuild
index 9c3a725ba7f6..5e8e3eb278dd 100644
--- a/sys-power/cpufreqd/cpufreqd-2.0.0.ebuild
+++ b/sys-power/cpufreqd/cpufreqd-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.0.0.ebuild,v 1.1 2005/11/27 09:46:06 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpufreqd/cpufreqd-2.0.0.ebuild,v 1.2 2005/12/22 11:02:28 brix Exp $
inherit eutils
@@ -28,6 +28,7 @@ src_unpack() {
if use nvidia; then
cd ${WORKDIR}/nvclock${NVCLOCK_VERSION}
epatch ${FILESDIR}/nvclock${NVCLOCK_VERSION}-fd.patch
+ epatch ${FILESDIR}/nvclock${NVCLOCK_VERSION}-fpic.patch
fi
}
diff --git a/sys-power/cpufreqd/files/nvclock0.8b-fpic.patch b/sys-power/cpufreqd/files/nvclock0.8b-fpic.patch
new file mode 100644
index 000000000000..a0e9783d113f
--- /dev/null
+++ b/sys-power/cpufreqd/files/nvclock0.8b-fpic.patch
@@ -0,0 +1,13 @@
+diff -urp nvclock0.8b/src/backend/Makefile.in nvclock0.8b-fpic/src/backend/Makefile.in
+--- nvclock0.8b/src/backend/Makefile.in 2005-12-22 11:57:27.000000000 +0100
++++ nvclock0.8b-fpic/src/backend/Makefile.in 2005-12-22 11:56:29.000000000 +0100
+@@ -5,7 +5,7 @@ RANLIB=@RANLIB@
+ system=@system@
+ HAVE_NVCONTROL=@HAVE_NVCONTROL@
+ OBJECTS=backend.o bios.o config.o error.o nv30.o nv31.o nv40.o info.o overclock.o i2c.o xf86i2c.o lm99.o f75375.o w83l785r.o libc_wrapper.o
+-CFLAGS=-I../.. -I../nvcontrol
++CFLAGS=-I../.. -I../nvcontrol -fPIC
+
+ ifeq ($(system), FreeBSD)
+ OBJECTS+=back_bsd.o
+Only in nvclock0.8b/src/backend: Makefile.in.~1.9.~