summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-06-08 03:27:44 +0000
committerJeroen Roovers <jer@gentoo.org>2009-06-08 03:27:44 +0000
commit1b3a6f3f532e943c1bb71312e7c6400475c528d1 (patch)
treee82a32411b97789268b0a7b3a0bc29b50ae0b7f3
parentStable for HPPA (bug #269889). (diff)
downloadgentoo-2-1b3a6f3f532e943c1bb71312e7c6400475c528d1.tar.gz
gentoo-2-1b3a6f3f532e943c1bb71312e7c6400475c528d1.tar.bz2
gentoo-2-1b3a6f3f532e943c1bb71312e7c6400475c528d1.zip
Apply patch by ipse (bug #272316). Touch up comments in ebuild for legibility.
(Portage version: 2.2_rc33/cvs/Linux i686)
-rw-r--r--app-admin/fam/ChangeLog9
-rw-r--r--app-admin/fam/fam-2.7.0-r5.ebuild89
-rw-r--r--app-admin/fam/files/fam-2.7.0-gcc44.patch11
3 files changed, 108 insertions, 1 deletions
diff --git a/app-admin/fam/ChangeLog b/app-admin/fam/ChangeLog
index 14e5fdf2a9c9..c997e2838e20 100644
--- a/app-admin/fam/ChangeLog
+++ b/app-admin/fam/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/fam
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/fam/ChangeLog,v 1.57 2009/06/07 15:54:05 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fam/ChangeLog,v 1.58 2009/06/08 03:27:43 jer Exp $
+
+*fam-2.7.0-r5 (08 Jun 2009)
+
+ 08 Jun 2009; Jeroen Roovers <jer@gentoo.org> +fam-2.7.0-r5.ebuild,
+ +files/fam-2.7.0-gcc44.patch:
+ Apply patch by ipse (bug #272316). Touch up comments in ebuild for
+ legibility.
07 Jun 2009; Jeroen Roovers <jer@gentoo.org> fam-2.7.0-r4.ebuild:
Fix typo.
diff --git a/app-admin/fam/fam-2.7.0-r5.ebuild b/app-admin/fam/fam-2.7.0-r5.ebuild
new file mode 100644
index 000000000000..96ed80fe4301
--- /dev/null
+++ b/app-admin/fam/fam-2.7.0-r5.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fam/fam-2.7.0-r5.ebuild,v 1.1 2009/06/08 03:27:43 jer Exp $
+
+inherit libtool eutils autotools
+
+DESCRIPTION="FAM, the File Alteration Monitor"
+HOMEPAGE="http://oss.sgi.com/projects/fam/"
+SRC_URI="ftp://oss.sgi.com/projects/fam/download/stable/${P}.tar.gz
+ mirror://gentoo/fam-2.7.0-dnotify.patch.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="|| ( net-nds/rpcbind >=net-nds/portmap-5b-r6 )
+ !app-admin/gamin"
+RDEPEND="${DEPEND}"
+PROVIDE="virtual/fam"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # large file patch #76679
+ epatch "${FILESDIR}/${P}-largefiles.patch"
+
+ # dnotify patch #43027
+ echo $WORKDIR
+ epatch "${WORKDIR}/${P}-dnotify.patch"
+
+ # use limits correctly -#89478
+ epatch "${FILESDIR}/${P}-limits.patch"
+
+ # fix gcc 4.1 problems
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+
+ # fix gcc 4.3 problems
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+
+ # fix gcc 4.4 problems
+ epatch "${FILESDIR}/${P}-gcc44.patch"
+
+ eautoreconf
+}
+
+src_install() {
+
+ make install DESTDIR="${D}" || die
+
+ dosed "s:local_only = false:local_only = true:g" /etc/fam.conf
+
+ doinitd "${FILESDIR}/famd"
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS TODO README
+
+}
+
+pkg_postinst() {
+
+ elog "To enable fam on boot you will have to add it to the"
+ elog "default profile, issue the following command as root to do so."
+ elog
+ elog "rc-update add famd default"
+
+ # temporary warning for people upgrading
+ # 6-12-03 foser <foser@gentoo.org>
+ if [ -e /etc/init.d/fam ]
+ then
+ echo
+ elog "IMPORTANT INFO FOR USERS UPGRADING FROM OLDER (<2.7.0) FAM VERSIONS :"
+ elog
+ elog "With the 2.7.0 version the fam daemon moved to sbin and was"
+ elog "renamed from 'fam' to 'famd'. These changes are for consistency"
+ elog "reasons also applied to the Gentoo init script. This means you"
+ elog "will have to remove fam from the default runlevel and add famd."
+ elog "This can be done by issueing the following commands :"
+ elog
+ elog "rc-update del fam"
+ elog "rc-update add famd default"
+ elog "rm /etc/init.d/fam"
+ elog
+ elog "The last command removes the old init script."
+ echo
+ fi
+
+}
diff --git a/app-admin/fam/files/fam-2.7.0-gcc44.patch b/app-admin/fam/files/fam-2.7.0-gcc44.patch
new file mode 100644
index 000000000000..c9ca0cba679e
--- /dev/null
+++ b/app-admin/fam/files/fam-2.7.0-gcc44.patch
@@ -0,0 +1,11 @@
+--- fam-2.7.0-orig/src/NFSFileSystem.c++ 2009-06-03 19:20:51.000000000 +0300
++++ fam-2.7.0/src/NFSFileSystem.c++ 2009-06-03 19:21:57.000000000 +0300
+@@ -97,7 +97,7 @@
+
+ attr_cache_timeout = ACREGMAX;
+
+- char * p;
++ const char * p;
+
+ if (strstr(opt, "noac")) {
+ f_noac = true;