summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-09-20 22:07:16 +0000
committerUlrich Müller <ulm@gentoo.org>2007-09-20 22:07:16 +0000
commit220014786b131b4c8bd9275976227453b993cfa7 (patch)
treee346ba2d4ae57478b087f73fca06e1f796f384f0
parentversion bump (diff)
downloadgentoo-2-220014786b131b4c8bd9275976227453b993cfa7.tar.gz
gentoo-2-220014786b131b4c8bd9275976227453b993cfa7.tar.bz2
gentoo-2-220014786b131b4c8bd9275976227453b993cfa7.zip
Version bump. Use autoloads.
(Portage version: 2.1.3.9)
-rw-r--r--app-emacs/thumbs/ChangeLog8
-rw-r--r--app-emacs/thumbs/files/51thumbs-gentoo.el14
-rw-r--r--app-emacs/thumbs/files/digest-thumbs-2.03
-rw-r--r--app-emacs/thumbs/thumbs-2.0.ebuild19
4 files changed, 43 insertions, 1 deletions
diff --git a/app-emacs/thumbs/ChangeLog b/app-emacs/thumbs/ChangeLog
index 3ee748b8aea2..b13bfa6eba61 100644
--- a/app-emacs/thumbs/ChangeLog
+++ b/app-emacs/thumbs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/thumbs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/thumbs/ChangeLog,v 1.13 2007/07/03 19:45:38 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/thumbs/ChangeLog,v 1.14 2007/09/20 22:07:15 ulm Exp $
+
+*thumbs-2.0 (20 Sep 2007)
+
+ 20 Sep 2007; Ulrich Mueller <ulm@gentoo.org> +files/51thumbs-gentoo.el,
+ +thumbs-2.0.ebuild:
+ Version bump. Use autoloads.
03 Jul 2007; Ulrich Mueller <ulm@gentoo.org> thumbs-1.8.ebuild:
Remove redundant functions.
diff --git a/app-emacs/thumbs/files/51thumbs-gentoo.el b/app-emacs/thumbs/files/51thumbs-gentoo.el
new file mode 100644
index 000000000000..a07a89b93c21
--- /dev/null
+++ b/app-emacs/thumbs/files/51thumbs-gentoo.el
@@ -0,0 +1,14 @@
+
+;;; thumbs site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'thumbs-find-thumb "thumbs" "Display the thumbnail for IMG." t)
+(autoload 'thumbs-show-all-from-dir "thumbs"
+ "Make a preview buffer for all images in DIR." t)
+(autoload 'thumbs-dired-show-marked "thumbs"
+ "In Dired, make a thumbs buffer with all marked files." t)
+(autoload 'thumbs-dired-show-all "thumbs"
+ "In dired, make a thumbs buffer with all files in current directory." t)
+(defalias 'thumbs 'thumbs-show-all-from-dir)
+(autoload 'thumbs-dired-setroot "thumbs"
+ "In dired, Call the setroot program on the image at point." t)
diff --git a/app-emacs/thumbs/files/digest-thumbs-2.0 b/app-emacs/thumbs/files/digest-thumbs-2.0
new file mode 100644
index 000000000000..8fd0eec35dde
--- /dev/null
+++ b/app-emacs/thumbs/files/digest-thumbs-2.0
@@ -0,0 +1,3 @@
+MD5 0408b699906107654cff2996742dcae3 thumbs-2.0.el.bz2 6521
+RMD160 c7c17b67618f5c5972e11a015debd500fa767688 thumbs-2.0.el.bz2 6521
+SHA256 e7f788f4e19c21b535024cdc49185e922fe91e39f7502486cca09a0125bb6935 thumbs-2.0.el.bz2 6521
diff --git a/app-emacs/thumbs/thumbs-2.0.ebuild b/app-emacs/thumbs/thumbs-2.0.ebuild
new file mode 100644
index 000000000000..77290b7c03b4
--- /dev/null
+++ b/app-emacs/thumbs/thumbs-2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/thumbs/thumbs-2.0.ebuild,v 1.1 2007/09/20 22:07:15 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs thumbnail previewer for image files"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki.pl?ThumbsMode"
+SRC_URI="mirror://gentoo/${P}.el.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="media-gfx/imagemagick"
+
+SIMPLE_ELISP=t
+SITEFILE=51${PN}-gentoo.el