summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-23 16:14:41 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-23 16:14:41 +0000
commit299b826e74a8f772fad397996ec5226dd677bd6c (patch)
tree394e636f07601579d658f918e44cab14348a0ba5
parentStable for alpha/amd64/arm/ia64/ppc/ppc64/s390/sh/sparc/x86, wrt bug #533076 (diff)
downloadgentoo-2-299b826e74a8f772fad397996ec5226dd677bd6c.tar.gz
gentoo-2-299b826e74a8f772fad397996ec5226dd677bd6c.tar.bz2
gentoo-2-299b826e74a8f772fad397996ec5226dd677bd6c.zip
Port gtk+-3 version. Fix missing MULTILIB_USEDEP on pkgconfig.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--x11-themes/gtk-engines-xfce/ChangeLog8
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild4
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r301.ebuild42
3 files changed, 51 insertions, 3 deletions
diff --git a/x11-themes/gtk-engines-xfce/ChangeLog b/x11-themes/gtk-engines-xfce/ChangeLog
index 5eb446c9c093..4239ebae46c9 100644
--- a/x11-themes/gtk-engines-xfce/ChangeLog
+++ b/x11-themes/gtk-engines-xfce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-engines-xfce
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/ChangeLog,v 1.167 2014/06/24 22:19:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/ChangeLog,v 1.168 2014/12/23 16:14:41 mgorny Exp $
+
+*gtk-engines-xfce-3.0.1-r301 (23 Dec 2014)
+
+ 23 Dec 2014; Michał Górny <mgorny@gentoo.org>
+ +gtk-engines-xfce-3.0.1-r301.ebuild, gtk-engines-xfce-3.0.1-r201.ebuild:
+ Port gtk+-3 version. Fix missing MULTILIB_USEDEP on pkgconfig.
24 Jun 2014; Michał Górny <mgorny@gentoo.org>
gtk-engines-xfce-3.0.1-r201.ebuild:
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild
index 5476ddb632b1..6bac35419aaa 100644
--- a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild,v 1.3 2014/06/24 22:19:41 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild,v 1.4 2014/12/23 16:14:41 mgorny Exp $
EAPI=5
MY_PN=gtk-xfce-engine
@@ -22,7 +22,7 @@ RDEPEND=">=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}]
!app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
)"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
S=${WORKDIR}/${MY_PN}-${PV}
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r301.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r301.ebuild
new file mode 100644
index 000000000000..9f7c4ce7b210
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r301.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r301.ebuild,v 1.1 2014/12/23 16:14:41 mgorny Exp $
+
+EAPI=5
+MY_PN=gtk-xfce-engine
+inherit xfconf multilib-minimal
+
+DESCRIPTION="A port of Xfce engine to GTK+ 3.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk2
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ xfconf_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}