summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-03-03 12:33:26 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-03-03 12:33:26 +0000
commit2a1c45ff79527a886bbe1aca6ba92a0da19b6829 (patch)
tree660dcb7d24aa13d94d714da304a0abeeb9a39a92
parentStable on hppa. (diff)
downloadgentoo-2-2a1c45ff79527a886bbe1aca6ba92a0da19b6829.tar.gz
gentoo-2-2a1c45ff79527a886bbe1aca6ba92a0da19b6829.tar.bz2
gentoo-2-2a1c45ff79527a886bbe1aca6ba92a0da19b6829.zip
Version bump
(Portage version: 2.1.2-r13)
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/bittorrent-5.0.7.ebuild84
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-5.0.73
3 files changed, 93 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 172059f00728..9e1a0ba4bd4f 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.104 2007/02/24 17:29:50 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.105 2007/03/03 12:33:26 armin76 Exp $
+
+*bittorrent-5.0.7 (03 Mar 2007)
+
+ 03 Mar 2007; Raúl Porcel <armin76@gentoo.org> +bittorrent-5.0.7.ebuild:
+ Version bump
24 Feb 2007; nixnut <nixnut@gentoo.org> bittorrent-5.0.5.ebuild:
Stable on ppc wrt bug 167783
diff --git a/net-p2p/bittorrent/bittorrent-5.0.7.ebuild b/net-p2p/bittorrent/bittorrent-5.0.7.ebuild
new file mode 100644
index 000000000000..120e38ff0a15
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-5.0.7.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.0.7.ebuild,v 1.1 2007/03/03 12:33:26 armin76 Exp $
+
+inherit distutils fdo-mime eutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://download.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="gtk"
+
+RDEPEND=">=dev-lang/python-2.3
+ gtk? (
+ >=x11-libs/wxGTK-2.6
+ >=dev-python/wxpython-2.6
+ )
+ >=dev-python/pycrypto-2.0
+ >=dev-python/twisted-2
+ dev-python/twisted-web
+ net-zope/zopeinterface
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+PROVIDE="virtual/bittorrent"
+
+DOCS="README.txt TRACKERLESS.txt public.key"
+PYTHON_MODNAME="BitTorrent"
+
+pkg_setup() {
+ if use gtk ; then
+ if ! built_with_use x11-libs/wxGTK unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ if ! built_with_use dev-python/wxpython unicode ; then
+ die "You must build wxGTK and wxpython with unicode support"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # path for documentation is in lowercase #109743
+ sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
+}
+
+src_install() {
+ distutils_src_install
+ use gtk || rm -f "${D}"/usr/bin/bittorrent
+
+ if use gtk ; then
+ doicon images/logo/bittorrent.ico
+ newicon images/logo/bittorrent_icon_32.png bittorrent.png
+ make_desktop_entry "bittorrent" "BitTorrent" bittorrent.png "Network"
+ echo "MimeType=application/x-bittorrent" \
+ >> "${D}"/usr/share/applications/bittorrent-${PN}.desktop
+ fi
+
+ newinitd "${FILESDIR}"/bittorrent-tracker.initd bittorrent-tracker
+ newconfd "${FILESDIR}"/bittorrent-tracker.confd bittorrent-tracker
+}
+
+pkg_postinst() {
+ einfo "Remember that BitTorrent has changed file naming scheme"
+ einfo "To run BitTorrent just execute /usr/bin/bittorrent"
+ einfo "To run the init.d, please use /etc/init.d/bittorrent-tracker"
+ elog
+ elog "If you are upgrading from bittorrent-4.4.0 you must remove "
+ elog "the ~/.bittorrent dir to make this version work. Remember to "
+ elog "do a backup first!"
+ elog
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-5.0.7 b/net-p2p/bittorrent/files/digest-bittorrent-5.0.7
new file mode 100644
index 000000000000..0a140deac956
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-5.0.7
@@ -0,0 +1,3 @@
+MD5 b0e74a4a0c1cb3ff8e75dfd4e032a956 BitTorrent-5.0.7.tar.gz 2489110
+RMD160 8c6563c93f0fcc65f6545d7932e3a5fb1ed5acfe BitTorrent-5.0.7.tar.gz 2489110
+SHA256 f291444f202ccbbb8a81578bc81f63c633032188395a671c0cd2b0f521c5a226 BitTorrent-5.0.7.tar.gz 2489110