summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-05-29 07:21:59 +0000
committerUlrich Müller <ulm@gentoo.org>2007-05-29 07:21:59 +0000
commit2eb49cfdea4918fc51d28cd3fbcc2fa398132094 (patch)
tree8f6192c85f92ededba7cb4624f5274adba90a22b
parentVersion bump (bug #179925). Dropped old versions. (diff)
downloadgentoo-2-2eb49cfdea4918fc51d28cd3fbcc2fa398132094.tar.gz
gentoo-2-2eb49cfdea4918fc51d28cd3fbcc2fa398132094.tar.bz2
gentoo-2-2eb49cfdea4918fc51d28cd3fbcc2fa398132094.zip
Correctly handle the no-toolkit case.
(Portage version: 2.1.2.7)
-rw-r--r--app-editors/emacs-cvs/ChangeLog5
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.990.ebuild6
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild6
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild6
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild6
5 files changed, 23 insertions, 6 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index 8234f04c695e..b868e345100d 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,11 +1,12 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.123 2007/05/29 06:26:35 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.124 2007/05/29 07:21:59 ulm Exp $
29 May 2007; Ulrich Mueller <ulm@gentoo.org> emacs-cvs-22.0.990.ebuild,
emacs-cvs-22.0.9999-r10.ebuild, emacs-cvs-22.1.50.ebuild,
emacs-cvs-23.0.0-r6.ebuild:
- Fix logic for USE=-motif. Variables in canonical order.
+ Fix logic for USE=-motif. Handle the case that no toolkit was specified
+ (i.e. -gtk -Xaw3d -motif). Variables in canonical order.
23 May 2007; Ulrich Mueller <ulm@gentoo.org> emacs-cvs-22.0.990.ebuild,
emacs-cvs-22.0.9999-r10.ebuild, emacs-cvs-22.1.50.ebuild,
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.990.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.990.ebuild
index 0b959f40e45b..cd1a9c484c10 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.0.990.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.990.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.990.ebuild,v 1.4 2007/05/29 06:39:00 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.990.ebuild,v 1.5 2007/05/29 07:21:59 ulm Exp $
WANT_AUTOCONF="2.61"
WANT_AUTOMAKE="latest"
@@ -122,6 +122,10 @@ src_compile() {
einfo "Configuring to build with motif toolkit support"
myconf="${myconf} --without-gtk"
myconf="${myconf} --with-x-toolkit=motif"
+ else
+ einfo "Configuring to build with no toolkit"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=no"
fi
else
myconf="${myconf} --without-x"
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild
index a403b19a655f..b062a83bbbf2 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild,v 1.17 2007/05/29 06:39:00 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild,v 1.18 2007/05/29 07:21:59 ulm Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -134,6 +134,10 @@ src_compile() {
einfo "Configuring to build with motif toolkit support"
myconf="${myconf} --without-gtk"
myconf="${myconf} --with-x-toolkit=motif"
+ else
+ einfo "Configuring to build with no toolkit"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=no"
fi
else
myconf="${myconf} --without-x"
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild
index b1c1ffe670f2..4d1dbe46226f 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild,v 1.9 2007/05/29 06:39:00 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.1.50.ebuild,v 1.10 2007/05/29 07:21:59 ulm Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -136,6 +136,10 @@ src_compile() {
einfo "Configuring to build with motif toolkit support"
myconf="${myconf} --without-gtk"
myconf="${myconf} --with-x-toolkit=motif"
+ else
+ einfo "Configuring to build with no toolkit"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=no"
fi
else
myconf="${myconf} --without-x"
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild
index b3d05d0acfdc..ebdc6147c202 100644
--- a/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild,v 1.14 2007/05/29 06:39:00 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.0-r6.ebuild,v 1.15 2007/05/29 07:21:59 ulm Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -138,6 +138,10 @@ src_compile() {
einfo "Configuring to build with motif toolkit support"
myconf="${myconf} --without-gtk"
myconf="${myconf} --with-x-toolkit=motif"
+ else
+ einfo "Configuring to build with no toolkit"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=no"
fi
else
myconf="${myconf} --without-x"